solaris系统基础管理_第1页
solaris系统基础管理_第2页
solaris系统基础管理_第3页
solaris系统基础管理_第4页
solaris系统基础管理_第5页
已阅读5页,还剩243页未读, 继续免费阅读

下载本文档

版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领

文档简介

系统培训

Solaris10X86第二部分系统基础管理系统基础管理系统的关闭与启动

Solaris10系统启动和关闭方面新的特性首先介绍Solaris10在系统启动和关闭方面的一些新的特性:(1)在启动过程中,ServiceManagementFacility(SMF)提供了新的选项。详细信息请见本书第11章——Solaris10的预测性自我修复。(2)在x86平台上,支持64位计算。手动启动可以进行64位计算的系统。在64位模式下启动x86系统,在选择启动的提示符下输入:bkernel/amd64/unix在以前的基于32位计算的Solaris版本中,如果启动兼容的64位计算能力,则不需要改变启动命令:bkernel/unix使用eeprom命令设置boot-file文件参数。系统基础管理在以前的Solaris版本中,boot-file文件参数设置为kernel/unix。在Solaris10中,boot-file文件参数默认设置为空(“”)。这时系统启动能自动检测,如果有64位计算能力,就会在x86平台上启动64位模式。直接手工设置boot-file文件参数的方法是:#eepromboot-filekernel/amd64/unix查看当前系统boot-file文件参数的方法是:#eepromboot-file使用内核调试模式(kmdb)启动系统。启动内核调试模式的方法是在启动方式的提示符下输入启动命令。如果是启动64位模式,则输入:bkernel/amd64/unix–k在基于系统32位模式下,启动64位计算能力,则输入:bkernel/unix-k系统基础管理系统的启动和关闭方面术语介绍1.运行级别和init状态运行级别是由一些代表系统服务运行状态的数字或字符表示。系统总是处于一个运行级别之中。与运行级别相关的是init状态,因为init进程维护着运行的级别。系统管理员可以通过init命令和svcadm命令来改变系统的运行级别。2.启动选项启动选项描述着系统是如何被启动的。不同的启动选项有以下几种。Interactiveboot:当系统启动时按照提示输入相应信息。Reconfigurationboot:当系统添加了新的硬件或虚拟设备时,选用此种启动方法。Recoveryboot:当系统出了故障时恢复启动。系统基础管理系统启动和关闭时注意事项在系统关闭时请注意以下这些事项:使用init和shutdown命令都可以关闭系统,使用进程和服务终止。使用shutdown命令来关闭服务器。当服务器被关闭之前,登录用户都将收到系统将被关闭的信息。只有具有超级用户权限才能使用shutdown和init命令来关闭服务器。系统启动时请注意以下这些事项:在SPARC平台上,启动命令boot在PROM级输入。在x86平台上,启动命令boot在主启动的子菜单中输入。系统基础管理如何关闭服务器服务器的一般运行级别是3,这时系统是多用户操作系统,也有NFS远程服务在运行。这就要求我们关闭服务器要小心,最好先查看一下用户的使用情况。查看谁在使用服务器的命令是who,如例5-1所示。例5-1查看谁在使用服务器。$whohollyconsoleMay707:30krytenpts/0May707:35(starlite)listerpts/1May707:40(bluemidget)我们在前面已经介绍过,关闭服务器最好的方法是使用shutdown命令,因为它会给在线用户一个通知。下面我们就介绍几个例子供大家参考系统基础管理例5-4在120秒后重新启动系统。#shutdown-i6-g120-yShutdownstarted.MonJun1415:46:16MDT2005BroadcastMessagefromroot(pts/4)onvenusMonJun1415:46:16...Thesystemvenuswillbeshutdownin2minutesChangingtoinitstate6-pleasewait#INIT:Newrunlevel:6Thesystemiscomingdown.Pleasewait.

…

Thesystemisdown.syncingfilesystems...donerebooting...

…

venusconsolelogin:Regardlessofwhyyoushutdow系统基础管理如何关闭单用户计算机例5-5在x86平台上将系统切换到运行级0#init0#INIT:Newrunlevel:0Thesystemiscomingdown.Pleasewait.…Thesystemisdown.syncingfilesystems...[11][10][3]donePressanykeytoreboot系统基础管理在x86平台上引导系统在x86平台上启动时有两种启动方式:按ESC键进入手动启动模式;默认进入自动启动模式。在进入手动启动模式后,我们可以看到菜单,如图5-1所示系统基础管理这是个启动顺序菜单,如果要改变系统的启动设备顺序,就将光标移动到<Entersetup>,然后按Enter键。读者若有疑问请查看系统的主板手册。在默认自动启动的情况下,会出现下面的提示:<<<CurrentBootParameters>>>Bootpath:/pci@0,0/pci-ide@7,1/ide@0/cmdk@0,0:aBootargs:Typeb[file-name][boot-flags]<ENTER>tobootwithoptionsori<ENTER>toenterbootinterpreteror<ENTER>tobootwithdefaults系统基础管理用户账号和用户组用户的概念是Solaris系统的核心。系统的所有进程和文件都由特定用户所拥有,并分配给特定的用户组。系统如果没有有效的用户和用户组,也就没有了任何的数据活动。Solaris管理员的首要任务就是管理用户。基于角色的访问控制(Role-BasedAccessControl,RBAC)是在Solaris8版本中首次引入的。RBAC是一种新的安全特性,它提供了一种灵活的方式将超级用户特权分给用户号,再也不必给一般用户以超级用户特权,而让他们执行一组需要超级用户特权的任务。系统基础管理用户的概述Solaris系统的每个用户都有一组惟一的标识号和特征参数来区别不同的用户,并在逻辑上形成一些相关的用户组。用户账号可以用于下列目的:生成Shell;交互执行应用;调度应用以按照制定的日期或时间运行;访问数据库应用和其他系统服务。除了用户账号之外,Solaris还有一些用于各种日常维护的系统账户,如root,daemon,bin,sys,lp,adm和uucp,它们的作用如下:执行特定任务的系统资源分配;运行mail服务器;运行web服务器;执行进程管理。系统基础管理Solaris10OS是开发者的乐园用户对Solaris系统的访问可以通过系统控制台或远程终端进行,这些控制台和终端可以工作在图形模式,也可以工作在文本模式。不管是哪一种,用户都需要向系统提交一组认证的证明,包括用户名和口令。用户在输入这些信息后,系统将把用户提交的口令与数据库(/etc/passwd)或隐蔽口令数据库(/etc/shadow)所存储的机密字符串进行比较。如果用户输入的口令已经加密,则它直接与口令数据库的加密项进行比较。如果口令匹配,则用户认证生效,用户可以允许产生一个Shell。每个用户除了账号和口令外,还有许多其他特征。这些包括:用户ID(UID):这是标记用户的一个整数编号。它从root用户开始编排(UID=0),其他UID顺序分配。但系统会保留1023以前的UID号用于系统账号。普通用户的UID从1024开始分配系统基础管理用户组:这是区分不同用户类型的一种灵活的分组机制。用户组不只是一组相关用户集合的概念,Solaris文件系统除了可以按照个别用户和全体用户来授予权限,还可以按照用户组指定文件访问的读、写和执行权限。每个UID都与一个基本组ID(GID)相关联,但它同时还可以与一个以上的辅助用户组关联。主目录:它是用户所创建的所有文件的默认存储位置。登录Shell:这是用户交互调用命令或编写程序的地方。Solaris提供各种不同的shell,包括Bourneshell(sh),Cshell(csh),Bourneagainshell(bash)和cornellshell(tcsh)。Shell的选择在很大程度上取决于用户的个人喜好,以及对类C编程结构和终端操作系统的熟练程度。用户注释:它通常为用户的全称。但系统账户的注释可以用来描述它们的作用。如一个Apache系统账户的注释就可以采用“Webserver”。系统基础管理管理用户账号

1.添加用户账号使用useradd命令可以增加用户账号,命令格式如下:useradd[-uuid|-ggroup]|-ddir|-sshell|-ccomment|-m[-kskel_dir]]login说明:u指定用户ID号;g制定所在组;d指定用户目录;s制定用户Shell;c用户的注释;m建立用户目录;login用户的登录名。系统基础管理例如,在例7-1中,添加新用户为chinaunix,用户所属组为sun,用户的主目录为/export/home/sun,这个用户的注释为“Suntestuser.”,用户所使用的Shell为bash。例7-1添加一个新用户。#useradd–u1003–g102–d/export/home/sun–c“Suntestuser.”–s/bin/bash–m–k/etc/skelchinaunix但在下列情况下,useradd命令的执行可能会失败:指定的UID已经被另一个用户所占用。UID是可以重复利用的,但是我们在重复使用某个UID之前一定要确保前一个用户已经不存在了。指定的GID在系统中不存在。我们可以在组数据库(/etc/group)中确认系统现有的GID。注释中包含有特殊字符,如双引号“”、感叹号“!”或斜杠“/”等。指定的shell不存在。此时我们可以确认一下指定路径下的shell是否确实存在,并且该shell是否已经列入shell数据库(/etc/shells)中。在创建用户账号之后,就要马上为用户账号设置一个口令。这可以通过passwd命令来实现系统基础管理例7-2修改或为用户设置口令。passwdchinaunix然后,按照系统提示输入两次口令即可系统基础管理2.修改用户账号属性我们可以使用usermod命令来修改用户账号。例如,如果希望将前面建立的chinaunix账号的UID从1004修改为1005,则可以使用下列命令:#usermod-u1005chinaunix从中可以看出,usermod命令的参数和useradd命令的参数基本上是一样的。3.删除用户账号如果有的用户账号不再需要了,我们可以使用userdel命令删除。例如,永久删除前面建立的chinaunix账号。#userdel-rchinaunix使用passwd-l命令可以将账号临时锁定,直到系统管理员给这个账号设定新的口令。系统基础管理Solaris管理控制台Solaris管理控制台(SMC,SolarisManagementConsole)是专门用来替代Admintool的,因为作为GUI系统管理工具,Admintool只提供了一组有限的工具,并且缺乏扩展性。对于那些经验丰富的老手来说,他们对于GUI工具的需求可能并不那么急迫,但是SMC确实提供了一种在单一界面下实现大量服务器的管理方法,并可以容易地实现它的核心接口功能的扩展。这意味着,我们可以将定制应用添加到管理工具箱中,或者通过适当的命令来实现特定系统管理应用的汇集。这里需要注意的是,SMC并不会给执行单机系统管理的系统管理员带来太多的好处,作为一种高级系统管理工具,它更适合那些涉及大量系统管理的站点使用。

系统基础管理Solaris管理控制台工具箱的概述Solaris管理控制台使用工具箱的观念。SMC有三个主要的组件:SMC用户机,也称为“SMC”或“控制台”;SMC服务器;SMC工具箱编辑器。若须引导每一个SMC组件的指示,请参阅引导SMC。关于“控制台”窗口及其组件的描述,请参阅控制台描述。SMC工具箱是已经以smcconf(1MB)注册的工具箱。它是文件夹、工具、传统应用程序及链接至其他工具箱的层次集合。请参阅打开服务器工具箱或打开本机工具箱以取得指示。关于创建或编辑工具箱的信息,请参阅SMC工具箱编辑器概述。系统基础管理根工具箱或容器称为“管理工具”。它的默认行为是寻找主机(本计算机)上的工具箱,并在SMC引导时将它链接起来。你可以将工具箱增加(链接)到“管理工具”。关于将工具箱新增至主要服务器工具箱的指示,请参阅将工具箱新增至管理工具。工具箱允许你将工具群组成一致性、用户导向的层次。此工具箱称为“本计算机”,是SMC服务器的默认工具箱,依照默认选项,工具箱包含下列种类(文件夹)及工具。系统状态:系统信息、日志查看器、处理、性能;系统配置:用户、项目、计算机和网络、补丁;服务:排定的工作;存储设备:安装及共同、磁盘、增强存储器;设备及硬件:串口。使用SMC工具箱编辑器,你可以修改现存的工具箱或者创建其他不同目的的工具箱,包含从一个工具箱管理多个服务器,以及将工具箱中相似的工具群组起来。工具箱可包含文件夹、工具,以及其他工具箱的链接。系统基础管理工具是一种与SMC兼容的应用程序/小组件,其紧密地结合至“控制台”。SMC工具是使用SMCSDK创建的。关于在“控制台”中查看执行中工具的指示,请参阅在控制台中装入工具。工具箱URL或链接是指向另外一个可能在当前的SMC服务器或任何其他SMC服务器上工具箱的指标。传统应用程序是一种不是SMC工具的应用程序;传统应用程序可以是script,X应用程序或URL。系统基础管理控制台描述依照系统的默认设置,控制台桌面共有三个窗口:导航窗口;查看窗口;信息窗口。下面是控制台桌面的窗口,如图8-1所示。导航窗口左方或“导航”窗口的功能就像网页中的框架一样,只要单击“导航”窗口中某个项目,则该项目便会出现在“查看”窗口中。“转动器”图标会显示在代表项目群组的项目旁边。单击该图标或连续双击图标旁边的文字可以展开或隐藏该群组。“导航”窗口显示与否,取决于“查看”菜单中的“显示”设置,详细信息请参阅查看菜单系统基础管理查看窗口右方或“查看”窗口会显示在“导航”窗口中选择的节点内容。内容可以是文件夹或工具。系统基础管理如果在“导航”窗口中所选择的节点是文件夹,该文件夹的内容就会显示在“查看”窗口中。如果选择的节点是简单的工具,就像“日期/时间”工具,时钟就可能会显示出来。如果选择的节点是复杂的工具,就像“用户管理员”,内容可能会是用户账户和电子邮件账户的子工具。选择用户账户节点和可能会显示出来的用户清单,并更改“动作”菜单使其允许编辑清单。信息窗口在控制台下方的“信息”窗口会视选择的“内容说明”或控制台事件标记来决定显示“导航”窗口中选择的对象的内容说明或警报类型清单。“信息”窗口显示与否,取决于“查看”菜单中的“显示”设置,详细信息请参阅查看菜单。系统基础管理工具列;位置列;状态列。工具列“工具列”和一般的软件的工具列一样,位于主控菜单的下方。位置列“位置列”位于控制台的工具列下方,包含一个“主工具箱”图标、“工具箱”字段(指示当前的工具箱以及在工具箱中所选择的项目),以及下拉菜单(包含最近所造访过的工具箱)。单击“主工具箱”图标,以打开主工具箱。从下拉菜单中选择工具箱,以便打开该工具箱。系统基础管理系统基础管理SMC启动SMC的运行主要是收集系统数据,提供查看数据的界面,并在这些数据的基础上执行相应的管理任务。对于不同的服务器,它可以存储本地化的工具箱。启动Solaris管理控制台的方法有两种。“控制台”的引导方式如下:从CDE前方面板上的“工具”菜单,或者在“应用管理程序”或“文件管理程序”中连续双击SMC图标。如果没有高分辨率的图形卡或监视器,SMC还可以采用命令行的方式启动。键入smc(依照系统默认设置,位于/usr/sadm/bin中),然后单击“Return”按钮就可以启动。SMC还提供了另外一种编辑运行模式,主要用于工具箱的修改或更新。键入smcedit(依照默认,位于/usr/sadm/bin中),然后单击“Return”按钮。SMC命令包括如下启动选项:系统基础管理auth-data,允许从文件中读取身份认证数据。-toolbox,约定工具箱名称从文件读入。另一种方式是指定一个指向工具箱所在的位置的URL地址。-domain,指定被管理系统的域名,它支持LDAP,DNS,NIS和NIS+域。DNS域的主机midnight的URL形式为dns:/midnight/。-hostname:port,指定被管理服务器的主机名和端口号,默认端口号为898。-J,将任意命令行选项传递给Java虚拟机,如heap的初始大小和最大值等。-rolepassword,指定角色名的口令。-password,指定用户名的口令。-rolename,指定执行SMC的角色。-t,在终端模式下执行SMC。-trust,允许所有下载代码都是可信的。-tool,指定执行的工具。-username,指定执行SMC的用户名。-yes,在默认情况下,对所有交互问题均以yes应答。系统基础管理注意:你可以用最终用户的身份引导SMC,但是某些工具或应用程序可能不能装入,除非以root登录,或者你在SMC服务器登录期间担任一个角色。“控制台”“快闪屏幕”会显示出来,并有消息指出程序正在装入。快闪屏幕会由“控制台”窗口取代。依据工具装入首选设置的设置值,“控制台”会打开工具箱,或者“登录”对话框会显示在“控制台”上方。如果你不能执行SMC,这可能是因为SMC服务器不在执行中或是处于有问题的状态。判断SMC服务器是否正在执行:以root登录,请键入/etc/init.d/init.wbemstatus。如果SMC服务器正在执行,你应该得到如下的响应:“SMCserverversion2.1.0runningonport898”。系统基础管理引导SMC服务器:以root登录,请键入/etc/init.d/init.wbemstart。在短暂时间之后,应该返回消息:“SMCserverstarted”。停止SMC服务器:以root登录,请键入/etc/init.d/init.wbemstop。应该返回消息:“SMCstopped”。系统基础管理Solaris10的预测性自我修复在Solaris10中,为构建和部署具有自我修复能力的系统和服务,Sun公司开发了一个新的体系结构,即预测性自我修复。预测性自我修复技术通过联机错误检测和自动恢复提供了一种突破性的服务可用性方案。Solaris10预测性自我修复的功能:自动检测诊断CPU,Memory,和I/O等子系统;在系统运行时自动离线故障设备;管理工具可以查看预测性自我修复的日志和结果;对诊断结果产生标准的信息日志;有在线支持Sun知识网站帮助错误诊断。系统基础管理Solaris10预测性自我修复的优势:通过系统诊断和隔离故障组件使得系统和服务更加有效;诊断故障组件的时间由以前的几天变成几秒;简单的管理方法降低了管理成本;在线支持Sun知识网站可以学到很多解决问题的方法和修复知识;具有拓展性的体系结构可以在不重起计算机的情况下修复和更新故障。系统基础管理预测性自我修复的功能主要体现在以下两个方面:FaultManagementArchitecture(FMA)即Solaris故障管理器,传统的错误信息被遥测事件所取代,而且还可自动诊断导致故障的原因,并启动自我修复活动,或者向系统管理员传递消息,指导系统管理员进行修复。FMA主要诊断和隔绝硬件故障,这使CPU、存储器和I/O问题可以在很短的时间内得到诊断和纠正。硬件和应用程序监控对系统管理员和用户是透明的,同时由于所有服务信息和相关性均存储在一个中央存储库中,因此能使错误报告得到简化。ServiceManagementFacility(SMF)即Solaris服务管理器,它主要用来诊断和修复软件方面的故障。SMF按照服务的相关性来启动、停止和管理服务,并兼容现有的管理习惯,如启动脚本等。预测性自我修复技术可使服务与管理更加简单、快捷,从而降低了管理成本。系统基础管理使用SMF来管理系统服务SMF是Solaris10操作系统中的软件服务管理工具。它替代了以前操作系统的/etc/*.d中的服务运行脚本。SMF理论概述对于使用过Windows的读者来说,SMF的功能类似“控制面板”中的“服务”;对于使用过Linux和UNIX的读者来说,这个功能就是替代部分目录/etc/rc*.d中的启动脚本程序(还有一本分没有替代)和超级服务器(inetd)的功能。另外,使用过Solaris9的读者知道,Solaris9是没有这个管理工具的,这是Solaris10的新功能。下面,就让我们来逐步了解SMF的管理功能。系统基础管理SMF特性简介SMF主要作为服务操作系统的Solaris10的服务管理工具,必然要有强大的服务管理功能。SMF作为新的管理工具,具有很多新的特性。下面先简单介绍一下SMF的特性,具体操作将在后面小节中介绍。SMF提供以下特性:当出现了管理错误、软件有Bug或者发生了硬件错误,导致了服务程序异常中止时,SMF可以自动按照一定的次序重新启动服务。使用svcs命令可以查看所有的服务,而使用svcadm和svccfg命令就可以管理这些服务。使用svcs-p命令就可以查看与本服务相关联的其他服务。通过服务快照设置可以很容易地实现服务的备份和恢复。通过svcs-x命令可以很容易的对服务进行调试,并且可以使每个服务都有自己的固定日志。所有的服务都可以通过svcadm进行启动和关闭,如果使用-t参数,则是临时的,系统重新启动后将不再保存。具有相应角色的非root用户也可以启动、关闭和修改服务。互相不隶属的服务在系统启动的时候是并行启动的,系统关闭的时候也是并行关闭的。这样系统启动和关闭速度就会很快。一些rc的启动脚本还是按照以前的方式来启动和关闭。系统基础管理SMF的概念SMF框架的部分术语需要我们了解,下面详细介绍这些术语。(1)SMFService。在SMF框架下的实际的功能单元就是服务实例。和Windows中的服务一样,这些服务有些是系统自带的,有些是由第三方开发的。就同一个服务而言,可能有多个版本;就一个版本而言,也可以在一个Solaris10上有多个服务实例。系统基础管理(2)服务标识。每个服务实例的命名就是服务标识,英文名叫FaultManagementResourceIdentifier,简写为FMRI。举个例子,rlogin的服务是svc:/network/login:rlogin,而/network/login就是rlogin的服务标识。同理,相同的FMRI形式还有以下这些:svc://localhost/system/system-log:default;svc:/system/system-log:default;system/system-log:default。系统基础管理一般,服务种类包括下面几种:application;device;milestone;network;platform;site;system。系统基础管理前面介绍过,SMF替代部分/etc/rc*.d中的启动脚本程序和超级服务器(inetd)的功能。对于init.d中的传统脚本,服务标识(FMRI)用lrc来代替svc。如lrc:/etc/rcS_d/S35cacheos_sh。但是这些传统脚本服务只能被SMF所监控,而不能被SMF所管理。在系统启动的第一时间,超级服务器(inetd)的控制文件/etc/inetd.conf中的设置就被自动地替换成SMF服务。替换的形式如下:network/<service-name>/<protocol>另外,RPC协议的服务被替换成:network/rpc-<service-name>/rcp_<protocol>需要说明的是,<service-name>是/etc/inetd.conf定义的服务名称。系统基础管理服务状态服务的状态有以下几种类型:degraded,服务已经启动,但是在受限制的状态运行。disabled,服务处于关闭状态。legacy_run,这个服务是不被SMF所管理的,但是可以被SMF所监测到。maintenance,维护状态。这个服务有大量的错误且应由管理者进行修复。offline,这个服务已经启动了,但是处于离线运行状态,没有在线运行。online,服务已经启动,并且在线运行。uninitialized,服务正处于初始化状态。系统基础管理SMFManifestsSMFManifests是含有服务或者服务实例的属性的XML文件。这些文件存储在/var/svc/manifest目录中。这个文件不被用来修改服务的属性。如果属性有错误的话,请运行svccfgimport命令来修改。详细的信息请参考service_bundle(4)帮助手册。SMFProfilesSMFProfiles也是XML文件,是系统启动时自动启动的服务列表。这些文件存在/var/svc/profile目录中。下面介绍两个文件:generic_open.xml,这个系统启动时会自动启动标准的Internet服务列表,是Solaris默认的启动服务。generic_limited_net.xml,这个策略文件是默认不启动的服务列表。在Internet中,只有sshd和NFS是默认启动的,大多数的服务是默认不启动的。系统基础管理SMF快照(Snapshot)每个服务实例都可以存储在快照里,下面就是几个标准的快照:initial,最初形成的快照;running,目前正在运行的快照;start,最后一次成功运行的快照。SMF服务总是运行着running的快照,如果这个快照不存在了,系统也会自动创建。使用命令svcadmrefresh可以刷新快照,使用命令svccfg可以查看或恢复为原来的快照。系统基础管理SMF和系统启动的关系SMF和系统启动的关系如图9-1所示。SMF提供了几种启动系统的新方法:如果你增加了系统服务,比如是第三方的产品,系统可能就不会自动启动这个服务。除非你使用下面的命令:#boot-mmilestone=all如果系统处于单用户状态,可以用这个命令进入多用户状态。#svcadmmilestone-tall当系统启动的时候,你可以选择verbose选项去看更多的信息,因为默认的启动将不显示任何信息。#boot-mverbose系统基础管理SMF与系统启动的关系

系统基础管理SMF的兼容性大多数的服务在Solaris10中被SMF所管理,在/etc/rc*.d中的早期Solaris版本服务也成为SMF服务的一部分。只有一部分第三方的服务还没有过度到SMF管理,这部分服务仍保留在/etc/rc*.d中。原来在/etc/inittab和/etc/inetd.conf所管理的系统服务现在已经改变,叫做legacy-runservices。用inetconv命令可以将这些legacy-runservices添加到服务配置数据库中。SMF可以查看这些服务,但不能进行管理。所以,SMF的自我修复功能等也就不能应用在这些服务上。所有应用服务将逐步过度到用SMF来管理,将来的新增服务将不再用/etc/inittab和/etc/inetd.conf来管理,也不再使用/etc/rc*.d下的脚本。监控SMF服务对系统管理员来说,监控服务是一个重要职责。监控的内容包括系统服务的状态和日志。监控的目的是使管理员及时了解系统服务信息,发现服务故障并及时采取措施。系统基础管理管理SMF服务管理SMF服务的内容包括启动、关闭、重起和恢复服务,是系统管理员有利的管理工具。在管理SMF服务的时候,用户可以不是root,具有服务管理的角色用户(RBAC)也可以来管理服务。1.如何关闭服务关闭步骤如下:(1)成为超级用户或者授权角色用户;(2)查看要关闭服务的依赖关系,如果有依赖本服务的其他服务,则本服务不能关闭;(3)关闭这个服务。系统基础管理例9-4关闭rlogin服务。查看有无依赖rlogin服务的其他服务:#svcs-Dnetwork/login:rlogin关闭rlogin服务:#svcadmdisablenetwork/login:rloginSTATESTIMEFMRI显示rlogin服务的状态:#svcsnetwork/login:rloginSTATESTIMEFMRIdisabled11:17:24svc:/network/login:rlogin系统基础管理如何启动服务启动步骤如下:(1)成为超级用户或者授权角色用户;(2)查看启动本服务所依赖的其他服务是否已经启动;如果本服务依赖的其他服务还没有启动,请使用svcadmenable-rFMRI命令来递归启动相关的服务;查看一个服务是否启动的命令是:#svcs-1FMRI|grepenabled(3)启动本服务。系统基础管理例9-5启动rlogin服务。使用svcs-lFMRI|grepenabled命令来查看启动rlogin服务所依赖的其他服务是否已经启动:#svcs-lnetwork/login:rlogin|grepenabledenabledtruerlogin服务已经启动。如果rlogin服务没有启动的话,启动rlogin服务的方法:#svcadmenablenetwork/login:rlogin最后,查看rlogin服务的状态:#svcsnetwork/login:rloginSTATESTIMEFMRIonline12:09:16svc:/network/login:rlogin系统基础管理如何重起服务服务的重新启动不需要分别使用disable和enable两个命令,只用一个restart命令就可以了。重新启动步骤:(1)成为超级用户或者授权角色用户;(2)重新启动服务,可使用命令:#svcadmrestartFMRI系统基础管理在维护状态下如何恢复服务步骤:(1)成为超级用户或者授权角色用户。(2)查看与维护状态下的服务相关联的进程是否已经关闭。一般情况下,与处于维护状态下的相关服务都应该已经关闭。无论如何,你应该确定关联进程是否都已经关闭。下面的命令就是显示与本服务相关联的其他进程。#svcs-pFMRI(3)如果需要,杀死相关联的进程:#pkill-9PID(4)到/var/service/log目录查找故障信息。(5)恢复服务,使用命令:#svcadmclearFMRI系统基础管理如何使用快照恢复服务如果服务的设置错误了,修复这个故障的方法就是使用最后能成功启动的快照进行恢复。在这个过程中,以前的console-login快照也将被使用。步骤:(1)成为超级用户或者授权角色用户。(2)运行svccfg命令:#svccfgsvc:>a.选择你想恢复的服务。注意:必须使用FMRI的全称,简写将不被系统接受。svc:>selectsystem/console-login:defaultsvc:/system/console-login:default>系统基础管理b.显示有用的快照列表。svc:/system/console-login:default>listsnapinitialrunningstartsvc:/system/console-login:default>c.选择恢复成start快照,这个start快照是最后的成功启动的快照。svc:/system/console-login:default>revertstartsvc:/system/console-login:default>d.退出svccfg控制模式。svc:/system/console-login:default>quit(3)更新服务设置。#svcadmrefreshsystem/console-login(4)重新启动服务。#svcadmrestartsystem/console-login系统基础管理如何使用不同的SMF策略步骤:(1)成为超级用户或者授权角色用户。(2)选择SMF策略。在下面命令中,generic_limited_net.xml策略将被使用:#svccfgapply/var/svc/profile/generic_limited_net.xml系统基础管理设置SMF服务本部分的内容包括修改服务内容和环境变量,以及如何将传统的服务发布为SMF服务。1.如何修改服务这部分我们介绍如何修改除了inetd所管理以外的服务。步骤:(1)成为超级用户或者授权角色用户。(2)按照需要改变控制文件。很多服务有一个或多个控制文件,这些控制文件可以在这些服务运行时被修改,但只有当服务被启动时,文件的内容才被使用。(3)重起服务。系统基础管理例9-6改变NFS服务的共享目录。改变NFS服务的共享目录必须要在定义共享目录的配置文件/etc/dfs/dfstab中做相应修改,然后重起NFS服务。#cat/etc/dfs/dfstabshare-Fnfs-orw/export/home重新启动svc/network/nfs/server服务后,设置才能生效:#svcadmrestartsvc:/network/nfs/server系统基础管理如何改变服务的环境变量在例9-7中,我们以修改cron服务的环境变量为例来看看如何修改服务的环境变量。例9-7修改服务的环境变量。(1)成为超级用户或者授权角色用户。(2)查看服务是否已经启动。#svcssystem/cronSTATESTIMEFMRIonlineDec_04svc:/system/cron:default系统基础管理在inetd中添加新的第三方服务后,再发布为svc服务步骤:(1)在/etc/inetd.conf文件中添加新的第三方服务。(2)使用下面的命令把inetd服务发布为svc服务:#inetconv-i/etc/inet/inetd.conf系统基础管理使用脚本来管理服务虽然Solaris10使用SMF来管理服务,但是还有少部分服务由传统的UNIX脚本来管理。下面这部分介绍的是传统的管理服务的方法。1.如何使用脚本程序来启动和关闭服务步骤:(1)成为超级用户或者授权角色用户。(2)关闭系统服务:#/etc/init.d/filenamestop(3)启动系统服务:#/etc/init.d/filenamestart(4)检查系统服务进程是否被启动:#pgrep-fservice例9-10启动和关闭NFS服务。(1)先关闭NFS服务:#cd/etc/inetd#/etc/init.d/nfs.serverstop#pgrep-fnfs系统基础管理(2)再启动NFS服务:#/etc/init.d/nfs.serverstart(3)检查NFS服务:#pgrep-fnfs101773101750102053101748101793102114查看更为详细的信息:#pgrep-fnfs-d,|xargsps-fpUIDPIDPPIDCSTIMETTYTIMECMDdaemon10174810Sep01?0:06/usr/lib/nfs/nfsmapiddaemon10175010Sep01?26:27/usr/lib/nfs/lockddaemon10177310Sep01?5:27/usr/lib/nfs/statdroot10179310Sep01?19:42/usr/lib/nfs/mountddaemon10205310Sep01?2270:37/usr/lib/nfs/nfsddaemon10211410Sep01?0:35/usr/lib/nfs/nfs4cbd系统基础管理如何增加运行脚本如果想增加控制脚本来启动和关闭服务,就复制这些脚本到/etc/init.d目录,然后在/etc/rc*.d的目录下创造这个脚本文件的软链接。步骤:(1)成为超级用户或者授权角色用户。(2)增加脚本到inti.d目录。#cpfilename/etc/init.d#chmod0744/etc/init.d/filename#chownroot:sys/etc/init.d/filename(3)创建软链接到rc*.d目录。#cd/etc/init.d#lnfilename/etc/rc2.d/Snnfilename(4)检查软链接。#ls/etc/init.d/*filename/etc/rc2.d/*filename系统基础管理如何删除脚本例9-11删除S99datainit脚本。#cd/etc/rc2.d#mvS99datainit_S99datainit系统基础管理使用SMF进行调试和修复SMF服务是有自我修复功能的,当自动修复不成功时,就需要管理员进行人工修复。服务的调试和修复方法有以下几种。1.如何修复SMF库错误SMF库存储着各种服务的信息。如果这个数据库出了问题,就需要使用备份数据库替换。数据库替换步骤:(1)成为超级用户或者授权角色用户。(2)停止svc.startddaemon。#pstop‘pgrepsvc.startd’(3)停止svc.configddaemon。#pkillsvc.configd(4)保存当前数据库。#cp/etc/svc/repository.db/etc/svc/repository.bad(5)用备份数据库替换当前库。#cp/lib/svc/seed/global.db/etc/svc/repository.db系统基础管理在系统启动时如何交互式启动服务步骤:(1)成为超级用户或者授权角色用户。(2)不启动svc.startddaemon,但是在控制台启动sulogin。okboot-mmilestone=none(3)以root登录到系统。(4)启动所有服务:#svcadmmilestone-tall(5)查看哪些服务没有启动。查看哪些服务没有启用命令svcs-l,在/var/svc/log日志文件中查看这些没启动服务的错误信息。(6)然后修复这些问题,检查这些服务是否启动。a.检查所有服务是否在线使用命令:#svcs-lb.检查login进程是否在运行使用命令:#svcs-lsystem/console-login:default(7)继续系统启动进程。系统基础管理3.当SMF服务没有启动时如何处理步骤:(1)成为超级用户或者授权角色用户。(2)查看问题服务信息。#svcs-xvsvc:/application/print/server:default(LPPrintService)State:disabledsinceWed13Oct200402:20:37PMPDTReason:Disabledbyanadministrator.See:/msg/SMF-8000-05See:man-M/usr/share/man-s1MlpschedImpact:2servicesarenotrunning:svc:/application/print/rfc1179:defaultsvc:/application/print/ipp-listener:default-x属性可提供其他相关服务的信息。(3)修复后,重新启动问题服务。#svcadmenableapplication/print/server系统基础管理Solaris10故障管理器Solaris10故障管理器(FMA)概述故障管理器是Solaris10新增的功能。通过FMA,使传统的错误信息被遥测事件所取代。当系统遥测到硬件有错误信息时(如图9-2所示),可以由errorhandling传递给FaultManagementDaemon(FMD)进行判断。判断后的故障事件交给agent来处理。agent可以启动自我修复活动,在不能进行自我修复的情况下,agent可以向系统管理员传递消息,指导系统管理员进行修复系统基础管理FMA示意图如图9-2所示。FMA具体有以下功能:自动诊断和隔绝硬件错误;产生新的遥测数据日志文件;不需要系统重新启动就可以诊断更新错误;产生标准的故障信息。系统基础管理FMA的主要逻辑结构如图9-3所示在图9-3中,由Errorhandlers对错误产生报告后,传递给诊断引擎进行处理并确定故障,最后由Agents使用记录、警告或关闭等方法处理。下面详细介绍这三部分的功能:Errorhandlers;对错误产生报告;传达对错误的处理。Faultmanagementdaemon(FMD)。系统基础管理Faultmanagementdaemon(FMD)结构如图9-4所示。FMD接到错误事件报告后,经过初步的判断,会将其分给相应的诊断引擎。如图9-4所示,诊断引擎种类有CPU/Mem,PCI等,诊断引擎分析判断,将错误事件整理为故障事件,反馈给FMD,FMD接收后整理为故障案例。故障案例形成后,交由agent进行修复和记录。系统基础管理综上所述,FMD有以下功用:FMD经过初步的判断将遥测事件送到适当的诊断引擎处理。大量事件会聚成故障案例,这些案例用UUID号来命名。故障案例的解决联系着一个或更多个故障事件。而故障事件又是由很多遥测事件所发现的。同类的故障案例对应着惟一的MSGID,MSGID就能在相应的Web站点上找到对应的解决方案。能够确定MSGID,解决问题就变得容易,故障案例就会被发到agents进行处理外,FMD还有以下功用:FMD为系统管理员提供了系统管理接口(fmd命令)。进行资源缓存。记录日志,主要是errorlog和faultlog等。Agents。记录日志信息;恢复系统稳定。系统基础管理作为Solaris10的新的功能,支持FMA的硬件还具有一定的范围。目前支持FMA的硬件范围:(1)对UltraSPARCIII,IVCPU/Memory硬件进行错误诊断;(2)自动修复CPU,memorypageretire错误;(3)在高端服务器上自动更新CHS;(4)对UltraSPARCPCIHBAs进行诊断;(5)恢复所有PCII/O错误;(6)BasicunbundledsupportatFCS:不久将要支持FMA的硬件范围(1)x86/OpteronCPU/Memory的支持;(2)x86/OpteronPCI,PCI-X的支持;(3)x86/Opteron/SPARCPCI-E的支持;(4)对SNMPtrap/MIB的支持;(5)SMARTdisk的支持;(6)对API管理程序的支持;(7)对硬盘和网络驱动器的支持。系统基础管理系统管理员使用的故障管理工具介绍故障管理工具是系统管理员的主要帮手。使用下列工具,可以帮助我们监控系统的运行状态,查看故障组件的信息,以及自动修复工作的结果。1.fmstat(1M)查看所有模块的时间和事件的统计信息;查看特定模块的详细信息。2.fmadm(1M)查看和管理查看、安装、卸载和重起模块;查看错误资源列表。3.mdump(1M)查看log日志在fltlog日志中查看的时间、UUID和MessageID;在errlog日志中查看时间、个别事件的详细信息。系统基础管理预测性自我修复技术是以插件模块的方式实现的,使用管理命令可以显示加载的模块:#fmadmconfigMODULEVERSIONSTATUSDESCRIPTIONcpumem-diagnosis1.3activeUltraSPARC-IIICPU/MemoryDiagnosiscpumem-retire1.0activeCPU/MemoryRetireAgenteft1.12activeeftdiagnosisenginefmd-self-diagnosis1.0activeFaultManagerSelf-Diagnosisio-retire1.0activeI/ORetireAgentsyslog-msgs1.0activeSyslogMessagingAgent综上所述,预测性自我修复的模块可以分为两类,一类是诊断引擎,另一类就是Agent(代理)。显而易见,CPU同时有自己的诊断引擎和Agent;FMD居然也有针对于自己的诊断引擎。而且,这些诊断引擎和Agent(代理)也有自己的版本号,而且随着硬件的发展而发展。STATUS是描述模块状态的,在系统不停机和不影响故障诊断的情况下,预测性自我修复模块可以自动被加载和卸载,也可以被快速更新。系统基础管理那么,每个模块的具体工作状态怎么样?fmstat将显示各模块的统计信息。#fmstatmoduleev_recvev_acptwaitsvc_t%w%bopensolvememszbufszcpumem-diagnosis000.00.200003.0K0cpumem-retire000.00.2000000eft000.00.20000552K0fmd-self-diagnosis000.00.2000000io-retire000.00.2000000syslog-msgs000.00.2000032b0系统基础管理解释一下其中的术语。ev_recv:模块接受的事件数;ev_acpt:模块受理的事件数;wait:等待检查的事件数;svc_t:模块接收事件的平均时间(ms);solve:模块加载后处理的总数。系统基础管理需要显示cpumem-diagnosis模块的详细信息时,使用-m参数:#fmstat-mcpumem-diagnosisNAMEVALUEDESCRIPTIONbad_ce0badceereportsbad_close0caseclosefornonexistentcasebad_cpc0badcpcereportsbad_cpu0badcpuereportsbad_cpu_asru0CPUASRUmissingormalformedbad_ddspe0badddspeereportsbad_det0detectormissingormalformed系统基础管理软件包和系统补丁的管理软件包的管理:

在Solaris10系统中,主要通过以下一些方法来管理软件包。installer:Solaris安装的图形界面;prodreg:Solaris软件包登记界面,可以添加、删除、显示软件包信息;Pkgadd等:使用传统的Solaris命令也可以进行软件包的管理。系统基础管理使用产品注册器(ProductRegistry)来管理软件Solaris产品注册器功能:查看已安装并注册的软件及一些软件属性的列表;查找并启动安装程序;安装附加软件产品;卸载软件。系统基础管理由图10-1可知,左侧是已经注册软件的列表,右侧是左侧选定软件的详细信息。下面有“新安装”和“删除”两个按钮。单击“新安装”按钮就会出现新安装软件的界面,如图10-2所示。选择需要安装的软件包,就可以进行软件的安装。系统基础管理图10-2安装软件界面

系统基础管理如果需要删除软件,如Apache,请在Solaris产品注册界面左侧选择“Apache2”后,单击“删除”按钮,就可以出现如图10-3所示的警告对话框。图10-3警告对话框单击“确认”按钮后,就可以将选定的软件删除。系统基础管理用包管理命令来管理软件(pkgadd)在以前的Solaris发行版中,如果你将Solaris修补程序管理工具与PatchPro2.1一起使用,则只能将带数字签名的修补程序添加到系统中。现在,Solaris10增强了pkgadd命令,使之可以将不带数字签名的修补程序添加到系统中。1.查看当前操作系统已经安装的软件包#pkginfo|moreapplicationSMCfreetfreetypeapplicationSMCgccgccapplicationSMCiconvlibiconvapplicationSMClibgcclibgcc系统基础管理查看介质中的软件包信息命令格式:pkginfo[-d[device|pathname]][-l]pkg_name参数:-d软件包所在的设备路径;-l软件包的详细描述;pkg_name软件包的名字。系统基础管理使用pkgadd安装软件包命令格式:pkgadd[-d[device|pathname]]pkg_name例10-2添加SunWaudio软件包。#pkgadd-d/cdrom/cdrom0/s0/Solaris_10/ProductSunWaudioProcessingpackageinstancefromAudioapplications(sparc)3.6.4,REV=1.98.08.13Copyright1998SunMicrosystems,Inc.Allrightsreserved.Usingasthepackagebasedirectory.系统基础管理使用建立spool目录的方法,在客户机上安装软件包有时,我们应该把安装的软件包都放在服务器的一个特定的目录下,其他的客户机就可以方便地从服务器上下载安装这些软件包。这个特定的目录就是spool目录。在服务器上建立spool目录。命令格式:#pkgadd-ddevice-name-sspooldirpkgid-ddevice-name:软件包的位置;-sspooldir:spool为目录的名,系统默认目录为/var/spool/pkg;pkgid:(可选项)软件包的名称。系统基础管理例10-3使用建立spool目录的方法,在客户机上安装SunWman软件包。把光盘中的SunWman软件包添加到指定spool目录:#pkgadd-d/cdrom/cdrom0/s0/Solaris_10/Product-s/var/spool/pkgSunWman在客户机上安装软件包:#mount-Fnfs-oropackage-server:/var/spool/pkg/mnt#pkgadd-d/mntSunWaudio在服务器上可以利用pkgrm-s命令从spooling目录中删除一个软件包:#pkgrm-s/var/spool/pkgSunWaudio系统基础管理使用pkgrm用于删除软件包命令格式:pkgrmpackage_name例10-4删除SunWaudio软件包。#pkgrmSunWaudioThefollowingpackageiscurrentlyinstalled:SunWaudioAudioapplications(sparc)3.6.4,REV=1.98.08.13Doyouwanttoremovethispackage?Y##Removinginstalledpackageinstance##Verifyingpackagedependencies.注:如果某个文件被多个软件包公用,则只当最后的包被删除时该软件包才被删除。

系统基础管理使用pkgchk校验软件包的安装pkgchk命令通过将软件包的属性及路径名与系统记录文件中的值对比来进行校验。命令格式:pkgchk[-lacvppath1[path2...]]-l:列出选定的组成软件包的文件的信息;-a:仅审计文件属性,不检查文件内容,默认是两者都检查;-c:仅审计文件内容,不检查文件属性,默认是两者都检查;-v:启用详细方式,边处理边列出文件;-p:仅检查列出的单个或多个路径名的准确度,“pathname”可以是一个或多个被逗号分隔的路径名系统基础管理例10-5检查/usr/sbin/pkgadd目录的内容和属性。#pkgchk-lp/usr/sbin/pkgaddPathname:/usr/sbin/pkgaddType:regularfileExpectedmode:0555Expectedowner:rootExpectedgroup:sysExpectedfilesize(bytes):867152Expectedsum(1)ofcontents:45580Expectedlastmodification:Jul0202:20:342004Referencedbythefollowingpackages:SunWpkgcmdsuCurrentstatus:installed完成谢谢安全阀基本知识如果压力容器(设备/管线等)压力超过设计压力…1.尽可能避免超压现象堵塞(BLOCKED)火灾(FIRE)热泄放(THERMALRELIEF)如何避免事故的发生?2.使用安全泄压设施爆破片安全阀如何避免事故的发生?01安全阀的作用就是过压保护!一切有过压可能的设施都需要安全阀的保护!这里的压力可以在200KG以上,也可以在1KG以下!设定压力(setpressure)安全阀起跳压力背压(backpressure)安全阀出口压力超压(overpressure)表示安全阀开启后至全开期间入口积聚的压力.几个压力概念弹簧式先导式重力板式先导+重力板典型应用电站锅炉典型应用长输管线典型应用罐区安全阀的主要类型02不同类型安全阀的优缺点结构简单,可靠性高适用范围广价格经济对介质不过分挑剔弹簧式安全阀的优点预漏--由于阀座密封力随介质压力的升高而降低,所以会有预漏现象--在未达到安全阀设定点前,就有少量介质泄出.100%SEATINGFORCE75502505075100%SETPRESSURE弹簧式安全阀的缺点过大的入口压力降会造成阀门的频跳,缩短阀门使用寿命.ChatterDiscGuideDiscHolderNozzle弹簧式安全阀的缺点弹簧式安全阀的缺点=10090807060500102030405010%OVERPRESSURE%BUILT-UPBACKPRESSURE%RATEDCAPACITY普通产品平衡背压能力差.在普通产品基础上加装波纹管,使其平衡背压的能力有所增强.能够使阀芯内件与高温/腐蚀性介质相隔离.平衡波纹管弹簧式安全阀的优点优异的阀座密封性能,阀座密封力随介质操作压力的升高而升高,可使系统在较高运行压力下高效能地工作.ResilientSeatP1P1P2先导式安全阀的优点平衡背压能力优秀有突开型/调节型两种动作特性可远传取压先导式安全阀的优点对介质比较挑剃,不适用于较脏/较粘稠的介质,此类介质会堵塞引压管及导阀内腔.成本较高.先导式安全阀的缺点重力板式产品的优点目前低压储罐呼吸阀/紧急泄放阀的主力产品.结构简单.价格经济.重力板式产品的缺点不可现场调节设定值.阀座密封性差,并有较严重的预漏.受背压影响大.需要很高的超压以达到全开.不适用于深冷/粘稠工况.几个常用规范ASMEsectionI-动力锅炉(FiredVessel)ASMEsectionVIII-非受火容器(UnfiredVessel)API2000-低压安全阀设计(LowpressurePRV)API520-火灾工况计算与选型(FireSizing)API526-阀门尺寸(ValveDimension)API527-阀座密封(SeatTightness)介质状态(气/液/气液双相).气态介质的分子量&Cp/Cv值.液态介质的比重/黏度.安全阀泄放量要求.设定压力.背压.泄放温度安全阀不以连接尺寸作为选型报价依据!如何提供高质量的询价?弹簧安全阀的结构弹簧安全阀起跳曲线弹簧安全阀结构弹簧安全阀结构导压管活塞密封活塞导向不平衡移动副(活塞)导管导阀弹性阀座P1P1P2先导式安全阀结构先导式安全阀的工作原理频跳安全阀的频跳是一种阀门高频反复开启关闭的现象。安全阀频跳时,一般来说密封面只打开其全启高度的几分只一或十几分之一,然后迅速回座并再次起跳。频跳时,阀瓣和喷嘴的密封面不断高频撞击会造成密封面的严重损伤。如果频跳现象进一步加剧还有可能造成阀体内部其他部分甚至系统的损伤。安全阀工作不正常的因素频跳后果1、导向平面由于反复高频磨擦造成表面划伤或局部材料疲劳实效。2、密封面由于高频碰撞造成损伤。3、由于高频振颤造成弹簧实效。4、由频跳所带来的阀门及管道振颤可能会破坏焊接材料和系统上其他设备。5、由于安全阀在频跳时无法达到需要的排放量,系统压力有可能继续升压并超过最大允许工作压力。安全阀工作不正常的因素A、系统压力在通过阀门与系统之间的连接管时压力下降超过3%。当阀门处于关闭状态时,阀门入口处的压力是相对稳定的。阀门入口压力与系统压力相同。当系统压力达到安全阀的起跳压力时,阀门迅速打开并开始泄压。但是由于阀门与系统之间的连接管设计不当,造成连接管内局部压力下降过快超过3%,是阀门入口处压力迅速下降到回座压力而导致阀门关闭。因此安全阀开启后没有达到完全排放,系统压力仍然很高,所以阀门会再次起跳并重复上述过程,既发生频跳。导致频跳的原因导致接管压降高于3%的原因1、阀门与系统间的连接管内径小于阀门入口管内径。2、存在严重的涡流现象。3、连接管过长而且没有作相应的补偿(使用内径较大的管道)。4、连接管过于复杂(拐弯过多甚至在该管上开口用作它途。在一般情况下安全阀入口处不允许安装其他阀门。)导致频跳的原因B、阀门的调节环位置设置不当。安全阀拥有喷嘴环和导向环。这两个环的位置直接影响安全阀的起跳和回座过程。如果喷嘴环的位置过低或导向环的位置过高,则阀门起跳后介质的作用力无法在阀瓣座和调节环所构成的空间内产生足够的托举力使阀门保持排放状态,从而导致阀门迅速回座。但是系统压力仍然保持较高水平,因此回座后阀门会很快再次起跳。导致频跳的原因C、安全阀的额定排量远远大于所需排量。

由于所选的安全阀的喉径面积远远大于所需,安全阀排放时过大的排量导致压力容器内局部压力下降过快,而系统本身的超压状态没有得到缓解,使安全阀不得不再次起跳频跳的原因阀门拒跳:当系统压力达到安全阀的起跳压力时,阀门不起跳的现象。安全阀工作不正常的因素1、阀门整定压力过高。2、阀门内落入大量杂质从而使阀办座和导套间卡死或摩擦力过大。3、弹簧之间夹入杂物使弹簧无法被正常压缩。4、阀门安装不当,使阀门垂直度超过极限范围(正负两度)从而使阀杆组件在起跳过程中受阻。5、排气管道没有被可靠支撑或由于管道受热膨胀移位从而对阀体产生扭转力,导致阀体内机构发生偏心而卡死。安全阀拒跳的原因阀门不回座或回座比过大:安全阀正常起跳后长时间无法回座,阀门保持排放状态的现象。安全阀工作不正常的因素1、阀门上下调整环的位置设置不当。2、排气管道设计不当造成排气不畅,由于排气管道过小、拐弯过多或被堵塞,使排放的蒸汽无法迅速排出而在排气管和阀体内积累,这时背压会作用在阀门内部机构上并产生抑制阀门关闭的趋势。3、阀门内落入大量杂质从而使阀瓣座和导套之间卡死后摩擦力过大。安全阀不回座或回座比过大的因素:4、弹簧之间夹入杂物从而使弹簧被正常压缩后无法恢复。5、由于对阀门排放时的排放反力计算不足,从而在排放时阀体受力扭曲损坏内部零件导致卡死。6、阀杆螺母(位于阀杆顶端)的定位销脱落。在阀门排放时由于振动使该螺母下滑使阀杆组件回落受阻。安全阀不回座或回座比过大的因

温馨提示

  • 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
  • 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
  • 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
  • 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
  • 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
  • 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
  • 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。

评论

0/150

提交评论