版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领
文档简介
1、UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY北京邮电大学与交换技术SIP协议分析SIP协议基础协议分析的要点 紧扣“协议的目的与目标” 谨记“协议分析的三要素” 语义 语法 时序 方向 顺序 定时 时刻考虑“协议设计基本原则” 注意“信令协议应该遵循的特点”UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING T
2、ECHNOLOGY如何开始学习协议初步认识一个协议 协议的基本概念 协议应用场景 协议三要素 协议的基础语义如何认识一个协议 协议设计的目的 协议设计的目标 协议设计的基本原则 协议的基本语 协议处理时序则UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY初步认识SIP协议 SIP协议设计目的与目标 SIP协议用户定位与可用性管理 SIP协议用户能力、会话建立与会话管理 SIP协议综述 SIP功能实体与组网 SIP会话处理过程UNIVERSIT
3、Y OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYSTATE KEY LABORATORY OF SWITCHING TECHNOLOGY ANDTELECOMMUNICATION NETWORKSIP协议设计目的与目标SIP协议的设计背景SIP协议的设计目的与目标互联网大发展中的协议体系= IPDNS最早于1983年由(Paul Mockapetris)发明; 原始的技术规范在882号因特网标准草案(RFC 882)中发布。基于的主CSSXML机位置发现DNS
4、HTMLURI/URLGET /sample/jsondata.html HTTP/1.1 Host:HyperText Transfer Protocol 超文本传输协议HTTPDNSHTTP是互联网上应用最的一种协议。设计HTTP最初的目的是为了提供一种发布和接收HTML页面的。TCPUDPHTTP基于URL的服务获取与传送基于URL的位操作IPv4 or IPv6 Unicast or Multicast置与协议类型:/服务器地址:端/路径/文件名Uniform Resource Locator 统一定位符最初由-用来作为万维网的地址。现在它已经被万维网编制为因特网标准RFC 1738U
5、NIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY如何与主机通信以获取? 如何标识主机上的?如何标识和寻址服务主机?目标主机的标识与寻址DNS系统(DNS :Domain Name System)是因特网的一项服务,它作为将和IP地址相互 更方便的的一个分布式数据库,能够使人互联网绑定11DNSIP NetworkGET /index.html HTTP/1.1 Host:UNIV
6、ERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY互联网应用的组网是平面组网目标的标识URI与URL/URN 如何标识互联网中的位置:URL(Uniform Resource Locator)名字:URN(Uniform Resource Name) urn:isbn:0-395-36341-1统一名(URN)如同一个人的名称,而统一定位符(URL)代表一个人的住址。换言之,URN定义某事物的,而URL提供查找该事物的百科The term Unifor
7、m Resource Locator (URL) refers to the subset of URIs that, in addition to identifying a resource, provide a means of locating the resource by describing its primary access mechanism (e.g., its network location). The term Uniform Resource Name (URN) has been used historically to refer to both URIs u
8、nder the urn scheme RFC2141, which are required to remain globally unique and persistent even when the resource ceases to exist orbecomes unavailable, and to any other URI with the properties of a name.RFC3986 统一标识符(URI)Uniform Resource Identifier一个用于标识某一互联网名称的字符串,该种标识用户对中(一般指万维网)的通过特定的协议进行交互操作URL是一
9、种URI,它标识一个互联网,并指定对其进行操作或取得该的统一标识符的文法:统一标识符的示例:URI = scheme : hier-part ? query # fragment hier-part= / authority path-abempty/ path-absolute/ path-rootless/ path-emptyfoo:/:8042/over/there?name=ferret#nose_/ / /|scheme|authority|path|query|fragmentURI = 协议类型:主管位置/路径?#片段标识UNIVERSITY OF POSTS AND TELE
10、COMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY目标的获取HTTP协议超文本传输协议(HTTP:HyperText Transfer Protocol)应用层通信协议最初设计目的是为了提供一种发布和接收HTML页面的协议设计请求语义GET:要求获得Request-URI指定的浏览器服务器POST:向Request-URI位置提交GET请求数据,请求处理(例如提交表单或者时序方向上传文件)定时32sPUT:向Request-URI其最.位置上传GET请求200响应应答顺序 2xx:请求已被服务器接收
11、、理解、并接受。反馈处理结果 UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYHTTP/1.1 200 OKDate: Thu, 30 Jul 2009 06:39:24 GMTServer: Apache/2.2.3 (CentOS) Content-Length: 1556Content-Type: text/html语法GET /sample/jsondata.html?nocache=1248935964991 HTTP/1.1Hos
12、t:User-Agent: Keep-Alive: 300 Connection: keep-alive Content-Type: text/plain目标的获取HTTP协议GET /sample/jsondata.htmlHTTP/1.1cd /sampleget ./jsondata.htmlUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYHTTP/1.1 200 OKDate: Thu, 30 Jul 2009 06:39:24 GM
13、TServer: Apache/2.2.3 (CentOS)Last-Modified: Sun, 09 Sep 2007 18:11:36 GMTContent-Length: 1556 Content-Type: text/html . 支持客户/服务器模式:协议的处理是C/S模式 浏览器是客户机,Web服务是服务器简单快速: 客户向服务器请求服务时,只需传送请求和路径 请求规定了客户与服务器的类型,路径代表请求的位置协议目的是寻址、标识、传输内容,压缩协议内容可提高有效 HTTP协议简单,使得HTTP服务器程序规模小,通信速度快灵活: HTTP传输任意类型的数据对象,类型由Content
14、-Type加以标记HTTP协议的设计目的是传输HTML无连接、无状态: 每次连接只处理一个请求,完成响应后断开传输HTML本身是可以无状态的 不请求消息的先后顺序及相互GET /sample/jsondata.html?nocache=1248935964991 HTTP/1.1 Host:User-Agent: Mozilla/5.0 Gecko/20090715 Firefox/3.5.1Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8Accept-Charset: ISO-8859-1,utf-
15、8;q=0.7,*;q=0.7Content-Type: text/plain互联网繁荣的基础HTTP协议UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYGET /2/article/information/v6/?x HTTP/1.1 Accept-Encoding: gzip, deflateHost: Connection: Keep-Alive Cookie: install_id=7015151153;互联网服务的发展轻量级的RES
16、T(Representational StateTransfer)操作模型 REST采用提供与相分离的模式所指的不只是数据,而是数据和表现形式的组合(数据如何作),即不仅有数据内容,也有数据化的服务逻辑标识符(URI:Uniform Resource Identifier) 的位置是语义由CREATE/READ/UPDATE/DELETE几种语义统一起来,替代各种逻辑语义扩展 增值业务的多样性的表现在的多样性,扩展增值业务表现在增值业务的扩展和抽象UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKI
17、NG AND SWITCHING TECHNOLOGY基于ROA的HTTP操作示例ROA:Resources Oriented ArchitectureCREATE READUPDATEDELETEHTTP:POSTGETPUTDELETEUNIVERSITY OF POSTS AND TELECOMMUNICATIOSTATE KEY LABORATORY OF NETWORKING AND SWITCHWeb服务与电信服务模式的区别Web服务是客户端状态驱动的服务 Web服务操作以“资源”的操作为中心 Web的服务端简单、无状态传统电信服务是服务端状态驱动的服务 传统电信服务以“状态” 的
18、操作为中心 传统电信服务端需要状态迁移与定时( 制)控 大部分用户不愿意也不希望参与到电信服务的 客户端根据请求结果自行解释“状态”状态迁移过程 传统电信服务采用对等模式 Web服务采用B/S模式UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYSIP协议的设计目标l 支持Internet Telephony架构l 支持与Internet协议与业务进行集成IP Networkjlli 10jlli 1
19、1支持Internet会话(考虑Internet特点) 全IP 平面(基于IP协议)(使用DNS主机地址)状况不均衡,主机状况千差万别尽量重用现有成熟协议目标不要做一个大而全的协议族(底层有TCP/UDP)与现有协议配合完成会话(如SDP)尽量做到与现有应用集成尽量重用现有协议的实现机制(如)尽量重用现有协议的语则(如HTTP)易于扩展 能够方便的扩展消息头域,消息参数和消息体 基于文本的协议UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY如
20、何标识和寻址服务主机如何标识和寻址用户终端如何标识主机上的如何标识用户如何与主机通信以获取如何与终端通信以建立呼叫SIP协议的设计目的SIP协议是一种应用层会话协议RFC3261 用于层 用于建立、修改、终止用户之间的多会话(邀请指定用户加入多会话)如何标识和找到用户及其终端User Location(用户定位)User Availability(用户可用性)User Capabilities(用户能力)用户是否可以接受会话邀请建立什么样的会话Session Setup(会话建立)Session Management(会话管理) 如何发起和建立会话如何管理和关闭会话UNIVERSITY OF
21、POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYSIP协议用户定位与用户可用性SIP协议如何标识用户SIP协议如何标识和寻址用户终端(用户定位) SIP协议用户可用性处理SIP协议名字机制STATE KEY LABORATORY OF SWITCHING TECHNOLOGY ANDTELECOMMUNICATION NETWORK如何标识用户:SIP协议用户地址SIP/SIPS URIURI = scheme : hier-part ? query # fragmen
22、t hier-part= / authority path-abemptySIP and SIPS Uniform Resource Indicators 格式:sip:user:passwordhost:port;uri-parameters?headers合法的SIP URI sip:alice sip:bob:5060 sip:bob;transport=udp sip:bob sip:5060;lr sip:;postd=pp22;user=phone合法的URI,但不是SIP URI tel:;postd=pp参考 RFC2806 (tel: URLs for Te
23、lephone Calls) RFC2396 (Uniform Resource IdeUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY支持与Internet业务集成2tel URI和SIP URI的区别?如何定位目标用户/终端DNS?DNSjlliIP Network10jlli 11UNIVERSITY OF POSTS AND TELECOMMUNI
24、CATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYURI能为子网地址吗?DNS主要维护内容是什么? 能管理user字段标识的用户吗?DNS返回的实际是绑定的公网地址如何定位目标用户/终端DDNS?DNSjlliDDNS ()标识:jlli 实际地址:11jlliUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYDNS协议
25、如何处理用户不的语义?基于动态DNS可以提供用户标识URI与IP地址的绑定SIP协议目标用户定位与用户可用性用户DNSREGISTER()jlli标识:jlli绑定地址: 11jlliUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY服务器如何处理邀请请求?可扩展丰富语义,描述请求的处理结果?服务器如何定位目标用户?基于归属地的用户定位与可用性管理DNS位置管理jlli管理AOR:jlli实际地址:5
26、11jllibupt. UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY归属地管理要求用户标识必须指向归属地域用户向归属地服务器,管理状态名字(Name Mapping)机制Name Mapping (名字机制) 提供了用户发布 提供了由用户机制(位置管理)地址的机制(管理)地址向用户的实际地址的用户地址(AOR: Address-of-Record) AOR 必须是 SIP 或 SIPS URI AOR一般被认为是一个用
27、户的公共公开地址(public address) AOR必须指向一个提供location service能力的domain,在这个domain中可以将提供的SIP URI映射为能够到用户的实际 URIUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY满足了用户定位与状态管理需求SIP协议用户能力、会话建立与会话管理会话的基本概念多终端的能力会话描述协议SDPSIP协议与SDP协议结合STATE KEY LABORATORY OF SWITCHI
28、NG TECHNOLOGY ANDTELECOMMUNICATION NETWORK会话的基本概念 何谓会话? 会话是一组多方和多接收方,及方与接收方之间的数据流(SDP:Session Description Protocol)UAUAUAUAUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY会话建立的三层含义会话建立的三层含义 实体之间逻辑连接的建立 实体之间承载连接的建立 实体之间流的建立电信应用平面电信传送平面电信应用平面电信传送平面应
29、用面应用用户面应用面 应用用户面会话逻辑连接会话会话流数据数据传送用户面传送面传送面传送用户面承载连接承载承载数据传送信令传送信令传送数据传送传送技术UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY会话与会话建立 会话是一组多方和多接收方, 和及方与接收方之间的方与接收方之间的数据传送会话逻辑连接承载/协商承载/协商流承载连接承载处理UA承载处理UAUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE
30、 KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY如何描述和交换用户能力?如何建立和管理会话?如何描述用户能力?AMRG.711AG.711ubitrate=6.3G.723语音 audioG.729QCIF=2H.263profile-level-id=42e01e; packetization-mode=1; max-br=452;max-mbps=11880H.264类型编码属性UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING
31、AND SWITCHING TECHNOLOGY如何描述多终端的能力?SDP的设计目的SDP设计目的:多方多会议的发布向会话的参与方发布会话(会议)的基本信息参与方可以根据SDP信息建立数据流连接SDP(Session Description Protocol)会话描述协议RFC2327给定的地址(会话基本信息的接入地址)按照类型和服务端口(描述)在合适的时间(会话时间描述给定的活动时间) 向指定的会话(会话基本信息的会话标识)SDP的基本内容会话的基本信息时间信息信息UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY
32、OF NETWORKING AND SWITCHING TECHNOLOGY没有定义如何传送Media description m= (media name and transport address) m= m= / a=* (zero or more media attribute lines) a=recvonlysendrecvsendonly inactive a=fmtp: 不仅还用户能力描述, 承载信息描述Time description t= (time the session is active) t= Session description v= (protocol ver
33、sion) o= (owner/creator and session identifier). o= s= (session name) c= (connection information - not required if included in all media) c= 基于告知模式的会话描述与会话建立UserAUserBSDPaRTPG.711SDPbRTPG.711UNIVERSTATE KEY LABIC SWGLOGY告知模式到底是谁邀请谁加入会话?两个会话描述是完全的UserA向UserB建立单向流UserB邀请UserA加入其创建的会话SessionBv=0o=userb
34、 2 3 IN IP4 s=session-bc=IN IP4 t=0 0m=audio 49920 RTP/AVP 0 a=rtpmap:0 PCMU/8000 m=0 RTP/AVP 31m=53000 RTP/AVP 32a=rtpmap:32 MPV/90000UserB向UserA建立单向流连接UserA邀请UserB加入其创建的会话SessionAv=0o=usera 1 2 IN IP4 s=session-ac=IN IP4 t=0 0m=audio 49170 RTP/AVP 0 a=rtpmap:0 PCMU/8000m=51372 RTP/AVP 31a=rtpmap:3
35、1 H261/90000m=53000 RTP/AVP 32a=rtpmap:32 MPV/90000会话邀请的基本语义终端终端终端服务器终端服务器会话邀请会话邀请会话邀请会话邀请会话邀请进展会话邀请进展会话邀请进展接受邀请会话邀请进展取消邀请接受邀请取消邀请/承载协商/承载重协商结束会话结束会话UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY如何实现过程与/承载协商/重协商过程?会话的建立UserAUserB会话邀请SDP会话邀请进展会话邀
36、请进展振铃接受邀请SDPUNIVERSSTATE KEY LABOCATIO WITCECHNOLOGY协商模式描述的终端能力用于协调终端之间的交互类型与占用承载与协商将UserB的能力传送到UserA,供UserA使用v=0o=userb 2 3 IN IP4 s=session-bc=IN IP4 t=0 0m=audio 49920 RTP/AVP 0 a=rtpmap:0 PCMU/8000 m=0 RTP/AVP 31m=53000 RTP/AVP 32a=rtpmap:32 MPV/90000将UserA的能力传送到UserB,供UserB选择v=0o=usera 1 2 IN I
37、P4 s=session-ac=IN IP4 t=0 0m=audio 49170 RTP/AVP 0 a=rtpmap:0 PCMU/8000m=51372 RTP/AVP 31a=rtpmap:31 H261/90000 m=53000 RTP/AVP 32a=rtpmap:32 MPV/90000会话的管理UserAUserB会话邀请会话邀请进展接受会话邀请会话修订SDP接受会话修订SDPUNIVERSITY OF POSTS ASTATE KEY LABORATORY OF NHNOLOGYSIP协议只需支持携带SDP即可在会话建立之后需能够重新协户能力承载/重协商v=0o=userb
38、 2 3 IN IP4 s=session-bc=IN IP4 t=0 0m=audio 49920 RTP/AVP 0 a=rtpmap:0 PCMU/8000 m=0 RTP/AVP 31m=53000 RTP/AVP 32a=rtpmap:32 MPV/90000v=0o=usera 1 2 IN IP4 s=session-ac=IN IP4 t=0 0m=audio 49170 RTP/AVP 0 a=rtpmap:0 PCMU/8000m=51372 RTP/AVP 31a=rtpmap:31 H261/90000 m=53000 RTP/AVP 32a=rtpmap:32 MPV
39、/90000STATE KEY LABORATORY OF SWITCHING TECHNOLOGY ANDTELECOMMUNICATION NETWORKSIP协议综述SIP协议的语义SIP协议的语则SIP协议的基本处理流程会话邀请的基本语义终端终端服务器用户会话邀请取消邀请会话邀请取消邀请nt会话邀请进展会话邀请进展接受/拒绝邀请接受/拒绝邀请协商结束会话结束会话UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYUser capabili
40、ties(用户能力)User availability(用户可用性)Session manageme(会话管理)Session setup(会话建立)User location(用户定位)SIP协议的基本请求SIP协议请求 INVITE 会话邀请 ACK 确认会话建立 CANCEL 取消会话邀请 BYE 终止会话 REGISTER 用户 OPTIONS 能力SIP协议操作特征 SIP协议架构采用C/S结构 SIP协议消息采用“Request”- “Response”机制 Client Server: Request Server Client: Responses Request: for t
41、he purpose of invoking a particular operation Response: for indicating the status of a request sent from the client to the server.消息处理与HTTP等类似,易于与其他应用集成UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYSIP协议的基本响应4xx Request Failure1xx Provisional最终响
42、应,代表请求处理失败,用临时响应,代表服务端接纳了用户的服务请求,并在服务过程中传递一些服务进展的信息100 Trying:服务处理过程中180 Ringing:被叫振铃户可以根据失败的进行处理。403 Forbidden:拒绝服务404 Not Found:呼叫地址不5xx Server Failure2xx Successful最终响应,代表请求处理因为服务最终响应,代表请求处理200 OK器内部失败,用户可以尝试向其他服务器发起服务请求500 Server Internal Error3xx Redirection6xx Global Failures最终响应,代表请求被重定向,用户可以
43、根据返回的重定向地址向新的地址发起服务请求302 Moved Temporarily:临时迁移到最终响应,代表请求处理因为全局失败,用户也不用再尝试其他服务器了600 Busy EverywhereUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY基本会话语义与消息UAUACall Stateful ProxyREGISTER200 OKINVITE100 TryingINVITE180 Ringing200 OK180 Ringing200
44、OKACKACKBYEBYE200 OK200 OKUNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGY呼叫(确认BYE请求处理完成)呼叫(会话邀请)主叫确认呼叫已经建立(确认INVITE 的处理响应传送)被叫摘机,呼叫建立(确认INVITE 请求被处理)已经向被叫振铃(请求的处理进展)呼叫被接纳(请求已收到,正在处理)发起呼叫(邀请用户加入会话)用户(绑定AOR与实际地址)SIP协议的消息结构语则Request-Line: Method SP
45、Request-URI SP SIP-Version CRLFStatus-Line: SIP-Version SP Status-Code SP Reason-Phrase CRLFheader-name HCOLON header-value *(COMMA header-value) CRLF文本协议,与HTTP等类似可用于携带承载/协商信息UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYMessage-BodyFrom请求发起者AOR
46、地址To请求目的端AOR地址Call-ID呼叫标识Contact请求发起人的实际地址CSeq消息序号Max-Forward生存跳数Via请求转发Content-Type消息体类型Content-Length消息体长度Message-HeaderStart-Linestart-line*message-headerCRLF message-body BNF范式BNF范式(BNF: Backus-Naur Form) 由John Backus 和 Peter Naur首先引入,语法的符号集计算机语言 |:= .(.)|斜体字: 内包含的为必选项: 内包含的为可选项: 内包含的为可重复0至无数次的项
47、: 表示在其左右两边任选一项,相当于OR的意思: “被定义为”的意思: 术语符号: 选项:最多出现一次: 重复项: 任意次数,: 分组0 次: 并列选项,只能选一个: 参数,在其它地方有解释UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYABNF范式ABNF 扩展的范式 RFC2234 定义,基于范式(BNF),但由它的语法和推导规则,用于描述作信协议(双向规范)的语言的形式系统,是IETF通信协议的描述语言规则 = 定义;注释CR LF“规
48、则”“定义”“注释”“CR LF”:是不区分大小写的非最终符号:由定义该规则的一系列符号组成:用于:(回车、换行)用来结束规则名字不区分大小写: , ,和都提及同一个规则规则名字由一个字母以及后续的多个字母、数字和连字符(减号) 组成用尖括号(“”)包围规则名并不是必需的UNIVERSITY OF POSTS AND TELECOMMUNICATIONSSTATE KEY LABORATORY OF NETWORKING AND SWITCHING TECHNOLOGYABNF示例SIP-message=Request / ResponseRequest=Request-Line*( message-header
温馨提示
- 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
- 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
- 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
- 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
- 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
- 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
- 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。
最新文档
- 小学六年级数学组合图形的面积教学设计-母题43组合图形的面积(一)
- 高一班会课《破茧·蜕变:戒除手机依赖重塑逐梦力》教学设计
- 高中信息技术必修一第四章“4.1算法及其特征”练习导学案教学设计
- 高三语文一轮复习“课程标准要求下的基础备考”精讲精练教学设计
- 初中九年级物理信息能源与可持续发展一轮复习教学设计
- 小学六年级信息技术《走进图形化编程世界》教学设计
- 初中科学八年级《欧姆定律的应用》衔接课教学设计
- 初中八年级数学教学设计:构造全等三角形常用方法的深度教学与核心素养培育
- 高中生物教学设计:内环境稳态与调节机制探究(人教版选择性必修1第1章第1节第2课时)
- 高中思想政治选择性必修三逻辑与思维“体会认识发展的历程”教学设计
- 2026年强制性产品认证应知应会培训考核卷(十一)
- 2026年法律职业资格考试商经法客观题练习带答案
- 检维修作业:安全要点与应急处置
- 2026金属基陶瓷复合材料技术创新与应用展望报告
- 2026-2027学年人教版七年级数学上册期中测试卷(带答案解析)
- GB 48063-2026交通运输北斗卫星导航系统定位模块通用技术规范
- 2025年江苏泰州市中考语文试卷真题及答案详解(精校打印)
- DB53T 1043-2021 复合矿物掺合料在混凝土中应用技术规程
- 痔疮术后饮食调理建议
- 婴幼儿伤害预防与处理配套教材电子课件(完整版)
- 中外航海文化知到课后答案智慧树章节测试答案2025年春中国人民解放军海军大连舰艇学院
评论
0/150
提交评论