软件性能测试与LoadRunner_第1页
软件性能测试与LoadRunner_第2页
软件性能测试与LoadRunner_第3页
软件性能测试与LoadRunner_第4页
软件性能测试与LoadRunner_第5页
已阅读5页,还剩54页未读, 继续免费阅读

下载本文档

版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领

文档简介

国家信息中心软件评测中心性能测试培训LoadRunner性能测试工具实践目录性能测试概述性能测试工具Loadrunner性能测试标准国际标准(IETF)RFC2544《网络互联设备基准测试方法》RFC1242《网络互联设备基准测试术语》RFC3511《防火墙性能基准测试方法》RFC2647《防火墙性能基准测试术语》国家标准GB/T16260《信息技术软件产品评价质量特性及其使用指南》GB/T17544《信息技术软件包质量要求和测试》其他SEI负载测试计划过程RBI方法PTGM性能测试模型(《软件性能测试过程详解与案例剖析》)性能测试指标吞吐量ThroughputGoodPutLR中的吞吐量一些性能测试书籍中的吞吐量响应时间(延迟)ResponsetimeLatency并发连接数新建连接数传输层性能指标Connections/connections/s并发事物数(transactions)新建事物数(TPStransactions/s)Bit/s并发用户数系统用户在线用户并发用户性能测试工具测试仪表SmartBits(2-3层性能测试)Avalanche&reflector(4-7层性能测试)商用测试工具HPLoadRunerIBMPerformanceTesterBorlandsilkperformaner免费测试工具WebApplicationStressToolwebload开源工具OpenSTAJmeter第一节LR简介LoadRuner简介5.Analyzedataand

pinpointsbottlenecks1.Recorduserinteractionsagainstclientapplicationintotestscript2.TurnscriptsintoVirtualUsersbyaddingtestdataanduserbehavior3.RunVirtualUserstogenerateload4.Monitorsystemperformanceduringloadtest性能测试一般流程LoadRunner的框架LoadRunner支持的企业环境Web:HTTP(S)SOAPWinsockFTPDNSRealMSMediaWAPiModeVoiceXMLPalmLDAPDatabases:OracleMSSQLServerDB2SybaseInformixODBCMiddleware:EJBsCORBACOMRMIJacadaBrokatTUXEDOMQSeriesPlatforms:WinNT/2000WinXPSunHPIBMLinuxERP/CRM:OracleApps.

SAPSiebelPeopleSoftClarifyLegacy:32705250VT100MailingServices:SMTPPOP3IMAPMAPIScriptingLanguages:C,Java,JavaScript,VBScript,VBA,C#,C++Browsers:IE

4.x-6.0Netscape4.x-6.xLoadRunner的实现方法LoadRunnerisacompletesolutiontoconductautomatedloadtestingbefore,during,andafterapplicationdeployment.

LoadRunnerallowsyouto...ScaleIdentifyDiagnosetheapplicationtoapredeterminedcapacity.businessprocesses

orsystemcomponentshavingtrouble.aproblemtopinpointtherootcause.LoadRunner组件脚本生成器:可录制或编写脚本,验证脚本的正确性VuGencontrollerAnalysis控制器:控制和执行场景,协调负载生成器实现大用户量的并发,并收集结果。分析器:实现结果数据的整理,并提供结果图和报告,提供一些分析图的工具。LoadRunner测试团队Tweak

SystemBasedonAnalysisPlanLoadTest1CreateVirtualUsers2ScenarioCreation3ScenarioExecution4ResultsAnalysis5LRExpertFunctionalExpertProjectManagerLRExpertFunctionalExpertProjectManagerLRExpertLRExpertSysAdminServerExpert(s)SysAdminServerExpert(s)LRExpert第二节性能测试规划性能测试规划在创建脚本之前要进行充分的规划PlanLoadTest1CreateVirtualUsers2ScenarioCreation3ScenarioExecution4ResultsAnalysis5Goals,businessprocesses,

usertype,userbehaviors,input

data,systemprofiling,

scenariodesign,andLoadRunner

installation规划阶段的内容建立负载测试的目标制定出可以用数量衡量的目标标准分析被测系统的业务运行状况确定要录制哪些商业流程(businessprocesses)确定业务高峰的负载情况和时间把需要测试的BP的操作步骤形成正式文档准备测试数据收集系统的技术信息确定系统的架构确定系统各部件的软件情况,使用什么样的数据库服务器?Web服务器?以帮助我们在合理的时间内确定系统瓶颈第三节测试脚本开发测试脚本开发方法录制脚本手工编写脚本脚本录制运行VuGen,创建新的脚本选择业务系统对应的网络协议,比如Web系统对应HTTP/HTML;设定录制选项RecordingOptions开始录制进行正常的业务流程的操作当业务操作完毕后,按StopRecording将录制结束保存脚本录制选项

RecordingBrowserRecordingProxyAdvancedCorrelation脚本的目录结构C:\web_project-Scripts--Action1.cvuser_init.cvuser_end.cLab1Script2.usrAssoonasthescriptissaved,thesearethefoldersthatyouwillseeLab1Script2Run-timeSettingsRunLogicPacingLogThinkTimeMiscellaneousSpeedSimulationBrowserEmulationProxyPreferencesContentCheckAvailableforallprotocols.SpecifictoWeb.常用的调试脚本的工具TestResultswindowExecutionLogSnapshotResultswindow

PageViewServerResponseClientRequestRun-TimeViewer在Web脚本中使用多个ActionWeb脚本中使用多个Action使用多个Action的典型的例子如何把不同的操作录制在多个Action中注意设定好开始和结束状态根据测试的目标来确定脚本的Action增强脚本事物点(transaction)参数化检查点集合点关联事物点(transaction)什么是transactionTransaction测量的内容Transaction的状态LR_AUTO/LR_PASS/LR_FAIL/LR_STOPTransactions中的思考时间如何处理?Transactions的相关设定简单演示参数化参数化的概念为什么要引入参数化什么时候需要参数化如何参数化输入数据参数化类型参数选择策略和参数更新策略参数化的一个技巧:如何突破参数显示白条限制修改C:\windows\vugen.ini中的ParamTable选项中的MaxVisibleLines=100的值参数化演示检查点checkpoint什么是检查点为什么要设置检查点检查点函数Web_find()Web_reg_find()检查点演示关联的基本概念WebServerLogin(UserNamejojoPasswordbean)Response(SessionID@@@12345)1.Login

UserNamejojoPasswordbean

2.Yoursessionid@@@12345

3.Requestforproductinfo

4.ProductinfofoundResponseProductinfoVuGenScriptRequestforproductinfo(SessionID@@@12345)脚本录制过程关联基本概念WebServerLogin(UserNamejojoPasswordbean)Response(SessionID@@@23456)1.Login

UserNamejojoPasswordbean2.Yoursessionid@@@12345

3.Requestforproductinfo4.ProductinfofoundResponseERRORSessionID12345hasexpiredLoginagaintogetproductinfoVuGenScriptRequestforproductinfo(SessionID@@@12345)脚本回放过程关联基本概念WebServerLogin(UserNamejojoPasswordbean)Response(SessionID@@@23456)Requestforproductinfo(<SessionID@@@23456>)ResponseHereistherequestedproductinfo1.……2.Your<session_id>3.……4.………CorrelatedVuGenScript解决方案关联过程自动关联创建关联规则手动关联Web_reg_save_paramLr_save_param手工脚本开发什么时候需要手工开发脚本手工开发脚本的方式通过LR自身的函数编写脚本通过对应开发语言编写脚本(C语言、JAVA、VB)手工创建脚本演示手工创建一个FTP上传文件的脚本手工创建一个JAVA的脚本第四节场景设计目标了解场景设计场景Runtimesetting(运行设置)性能监控器(PerformanceMonitors)什么是场景scriptsrun-timesettingsloadgeneratorsreal-timemonitorsvirtualusersElementsofaScenarioScenarioAscenarioisafilethatdefineswhichVuserstoexecute,thenumberofVuserstorun,thegoalsofthetest,whichcomputerhoststheVusersandtheconditionsunderwhichtoruntheloadtest.两种类型场景的比较ManualScenariomainpurposeistolearnhowmanyVuserscanrunconcurrentlygivesyoumanualcontroloverhowmanyVusersrunandatwhattimesGoal-OrientedScenariogoalmaybethroughput,responsetimeornumberofconcurrentVusersLoadRunnermanagesVusersautomatically如何选择两种类型的场景ScenarioOutlineScenarioTypeManualscenariowith1,000concurrentVusersScriptshoulddefine‘Update’

Whenrunningtheloadtestatpeakload,achieve1,000concurrentusersGoal-OrientedscenariowithTransactionResponseTimeasthe‘GoalType’Scriptshoulddefine‘Search’

TransactionWhenrunningtheloadtestduringnon-peakhoursachieveresponsetimeof8secs.with2,000concurrentusersWhenrunningtheloadtestinpeakhoursachieveresponsetimeof12secswith5,000concurrentusersRuntimesettingRunLogicPacingLogThink-TimeMiscellaneousDEMO:如何进行测试Transactions不能说明一切Transactionsmeasurethetimerequiredforabusinessprocess.Theperformanceoftransactionssuggestsapictureofthesystemcomponent’sbehavior.Transaction:searchExercisestheWeb,application

anddatabaseserver Thistransactionperformed

poorlywitharesponsetimeof30seconds.Transaction:buyExercisestheWeband

applicationserver Thistransactionperformed

asexpectedwitharesponse

timeof1min.性能监控(PerformanceMonitors)性能指标监控基本设置系统资源监控Internet/IntranetDatabaseserverAppserversWebserversClients场景设计常见问题如何突破Controller可用脚本五十条限制修改Max_num_of_scripts的值(LR8.0中可以设置)8.1中没有这个选项如何在命令行下启动Controller如何解决由于设置引起的运行失败问题几种不同超时的处理方法DEMO:问题解决演示第五节测试执行执行Scenario之前的准备工作AddperformancemonitorsinRuntab.Specifyalocationtosavethescenarioresultsanddecideonanamefortheresults.Establishrendezvouspolicies,ifany.测试执行过程中的团队合作NetworkAdministratormonitorsnetworkperformancewhileloadtestisrunningDatabaseserverAppserversWebserversLoadtestengineermonitorstransactionperformanceAndservermonitorsviaLoadRunnerControllerApplicationorDatabaseAdministratormonitors

remotesystemperformance

duringloadtestScenarioExecution过程:DebugRunDEBUGRUN3-5VusersISOLATE

TOPTIME

TRANSACTIONS20%LOADSCALABILITY100%++LOADFULLLOAD100%Objective:VerifythatparameterizeddataworksunderconcurrentusageRun-timeSettings:Useextendedloganddatareturnedbyserverand

ignorethinktimesWhattolookfor:Noerrors.Thissignifiesthatyouarenowreadyto proceedwiththeloadtest ScenarioExecution过程:IsolateTopTimeTransactionsSCALABILITY100%++LOADFULLLOAD100%Objective:Isolatetransactionsthathaveperformanceproblems

irrespectiveofloadtofindifthereareanybottlenecksRun-timeSettings:UsestandardlogandignorethinktimeWhattolookfor:Theworstperformingtransactions.Thismightbein absolutetime(longest)oritmightbeagainst

somemeasurablegoal(2Xasslowasthetestobjective)DEBUGRUN3-5VusersISOLATE

TOPTIME

TRANSACTIONS20%LOADScenarioExecution过程:FullLoadSCALABILITY100%++LOADObjective:VerifythatthesystemperformsasexpectedunderloadRun-timeSettings:TurnloggingoffandenablethinktimeWhattolookfor:CompareyourloadtestgoalstothetestresultsDEBUGRUN3-5VusersISOLATE

TOPTIME

TRANSACTIONS20%LOADFULLLOAD100%ScenarioExecution过程:ScalabilityTestObjective:Verifiestheloadlimitthatcanbehandledbeforemore

resourcesarerequired Run-timeSettings:TurnloggingoffandenablethinktimeWhattolookfor:Loadtestgoalshouldbeexceeded,and2Xresponse timeofyourfullloadtest(100%)shouldbeachievedDEBUGRUN3-5VusersISOLATE

TOPTIME

TRANSACTIONS20%LOADFULLLOAD100%SCALABILITY100%++

LOAD第六节结果分析哪里出现了问题?AppserversDatabaseserversWebserverAnylinkinthechainbetweenbrowseranddatabasecouldbethecauseofanapplicationfailureorperformancedeg

温馨提示

  • 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
  • 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
  • 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
  • 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
  • 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
  • 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
  • 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。

评论

0/150

提交评论