版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领
文档简介
公共信用信息第2部分:数据交换规范PubliccreditinformationPart2:SpecificationHYPERLINK安徽省质量技术监督局发布I本部分按照GB/T1.1-2009给出的规则起草。——第1部分:数据元目录;——第2部分:数据交换规范。HYPERLINK1公共信用信息第2部分:数据交换规范1范围件。凡是不注日期的引用文件,其最新版本(包括所有的修改单)适用于本文件。DB34/T2733.1-2016公共信用信息第1部分:数据元目录3术语和定义2DB34/T2733.2—2016周期性cycle按照约定的频率进行数据交换传输。一次数据交换数据包大于100MB。小数据包smalIdatapacket一次数据交换数据包小于等于100MB。HTTP状态码HTTPstatuscode用以表示网页服务器HTTP响应状态的3位数字代码。它由RFC(RequestForComments)规范定义的,并得到RFC2518、RFC2817、RFC2295、RFC2774、RFC4918等规范扩4交换指标项交换的内容能反映分析对象某一特征的指标。这种指标具有单一性和精确性。描述一个交换指标项的属性包括以下内容:——内部标识符;——类型长度;——中文名称;——定义/说明。5数据交换总体架构HYPERLINK数据交换基于电子政务外网,数据交换总体架构图如图1传播或其他用途3DB34/T2733.2—2016图1数据交换总体架构示意图6数据交换方式6.1基于数据库的交换方式6.1.1结构说明基于数据库的交换方式结构图见图2。<节点1>交换通道<节点2>数据提供方数据提供方①①数据接收方数据接收方库③③ →节点1发送数据给节点2…节点2发送数据给节点1图2基于数据库的交换方式4基于数据库的数据交换方式适用于实时、周期性、大数据包、小数据包、结构化数据场景。6.1.3数据库交换参数基于数据库的数据交换方式,需要提供如下参数信息(示例见附录B):——前置数据库类型;——前置数据库地址(数据库所在的服务器IP地址);——前置数据库端口号;——前置数据库服务名;——用户名(登录数据库所需用户名);——密码(登录数据库所需密码);——交换实体(表或者视图名称);——交换指标项;——交换周期。6.2基于文件的交换方式基于文件的交换方式结构图见图3。<文件交换>节点1交换通道④②-监控--④②监控一①解析在 图3基于文件的交换方式基于文件的交换方式适用于实时、周期性、大数据包、小数据包、结构化数据、非结构化数据、半结构化数据场景。6.2.3结构化文件信息规范5DB34/T2733.2—20结构化文件信息规范参见附录B。6.2.4文件命名方法文件的命名方法为:[业务名称][日期][文件编号].[文件后缀名],只有一个文件时文件编号为001,多个文件时采用文件编号依次增加。不同日期要求的文件格式表示方法如下:——针对日文件:[业务名称]yyyyMMddNNN.xls——针对月文件:[业务名称]yyyyMNNN.xls 针对年文件:[业务名称]yyyyNNN.xls6.3基于服务接口的交换方式6.3.1服务接口结构说明基于服务接口的数据交换方式结构图见图4:交换平台①服务调用服务调用②④②④---服务调用-①③服务访问请求服务访问---…③服务访问服务访问请求服务订阅 节点1提供服务接口节点2提供服务接口6.3.2适用场景L图4服务接口交换方式基于服务接口的交换方式适用于周期性中小数据包、结构化数据是非结构化数据、半结构化数据场6.3.3服务接口协议格式服务接口协议格式分为服务接口请求对象格式和服务接口返回对象格式。服务接口请求对象格式样例参见附录A。服务接口返回对象格式样例参见附录A,服务接口返回对象样例参见附录B。7认证与授权6服务接口认证授权分为数据交换平台认证授权与数据提供方的认证授权。7.2数据交换平台认证授权通过交换平台对数据接收方所需要访问的服务生成对应的认证授权代码,由数据交换平台提供服务标识和访问认证标识参数信息。7.3数据提供方认证授权支持参数认证(由数据提供方提供用户名与密码),支持Token认证(由数据提供方提供访问认8异常处置8.1信用数据交换应建立异常处理机制解决数据交换过程中发生异常情况。8.2对异常进行分析确定异常产生的原因,根据分析结果协调资源解决异常情况恢复数据交换。8.3异常处置中的状态码使用HTTP状态码表示。8.4异常处置流程分为以下步骤:a)异常捕获:数据交换平台建立交换全过程异常捕获功能,获取异常情况并提供异常预警功能。b)异常分析:对于发生的异常进行分析,并确定异常原因。c)异常处理:协调处理异常所需相关资源,对异常情况进行统筹处理恢复数据交换。HYPERLINK7(规范性附录)<?xmlversion="1.0"encoding="UTF-8"?><xs:schemaxmlns:xs="/2001/XMLSchema"elementFormDefault="qualified"><xs:elementname="DBExRequest"><xs:elementref="esb_service_id"/><xs:elementref="esb<xs:elementname="esb_service_id"ty<xs:elementname="esb_token"type="xs:string"/>参数类型参数说明访问服务标识,关联以下8个属性:senderCode:数据请求发送方机构代码senderName:数据请求发送方机构名称resourceName:资源名称(业务名称)时间戳<?xmlversion="1.0"encoding="UTF-8"?><xs:schemaxmlns:xs="/2001/XMLSchema"elementFormDefault="qualified"><xs:elementname="DBExData">8name="esb_service_id"type="xs:name="esb_token"type="xs:strname="recordCount"type="xs:name="dataSet"type="DataSetname="recordData"type="RecordDataname="operationType"type="xs:strname="unitData"type="UnitDataname="unitIDName"type="xs:strname="unitDisplayName"type="xs:stname="unitValue"type="xs:strref="recordData"max0ccurs="unboun<xs:complexTypename="RecordDataType"><xs:elementref="operationType"/><xs:elementref="unitData"max0ccurs="unbounded"/><xs:elementref仅供端a品交流使用,请勿传播或其他用途<xs:elementref仅供端a品交流使用,请勿传播或其他用途<xs:elementref="unitDisp<xs:elementref="unitValue"/>数据集(DataSetType)参数表见表A.3。数据项(UnitDataType)参数表见表A.5。9DB34/T2733.2—2016参数类型参数说明参数类型参数说明参数类型参数说明参数类型参数说明HYPERLINK(规范性附录)数据交换样例见表B.1.说明数据库类型(数据库所在的服务器IP数据库服务名用户名table001(表或者视图名称)交换指标项具体交换实体(表或者视图)中的列信息交换周期每日一个excel文件只能对应一个数据库实体(数据库表),每个交换指标项有确定的数据库表列对况。对于需要标注数据状态信息的数据请在excel文件中增加“数据状态”列(1:新增数据;2:更新数据;3:删除数据)表头信息不需要在excel,中体现(在文件名中已经有该信息)BE统一社会信用代码邮政编码×××单位×X××单位X×××单位1一个文件只能对应一个数据库实体(数据库表),每个交换指标项有确定的数据库表列对应存储。对于需要标注数据状态信息的数据请在文件中增加“数据状态”列(1:新增数据;2:更新数据;3:删除数据)。文件(F)编辑(E)格式(O)查看(V)帮助(H)统一社会信用代码(%PPP%)企业名称(%PPP%)邮政编码(%PPP%)企业地9×××××××X1066××××4(%PPP%)×××单位(%PPP%)23××××(%PPP%)×××(%PPP%)19×××××××X1066××××5(%PPP%)×××单位(%PPP%)24××××(%PPP%)××9×××××××X1066××××6(%PPP%)×××单位(%PPP%)25××××(%PPP%)×××(%PPP%)39×××××××X1066××××7(%PPP%)×××单位(%PPP%)26××××(%PPP%)×××(%PPP%)19×××××××X1066××××8(%PPP%)×××单位(%PPP%)27××××(%PPP%)×××(%PPP%)1图B.2TEXT文件格式示例文件(F)编辑(E)格式(O)查看(V)帮助(H)统一社会信用代码,企业名称,邮政编码,企业地址,数据状态9×××××××X1066××X×4,×X×单位,23××××,×××,19×××××××X1066××××5,×××单位,29×××××××X1066××××6,×X×单位,25××××,×××,39××XXX××X1066××××7,XXX单位,26×XXX,×X×,19×××××××X1066××××8,×××单位,27××××,×××,1<?xmlversion="1.0"encoding="UTF-8"?><xs:schemaxmlns:xs="/2001/XMLSchema"elementFormDefaul<esb_service_id>1301</esb_ser<esb_token>f26461b6-ala9-4bd6-aa01-b42e000ce57b</e<reciverCode>000012</reci<
温馨提示
- 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
- 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
- 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
- 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
- 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
- 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
- 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。
最新文档
- 加气混凝土切割工岗位安全教育考核试卷含答案
- 拖拉机涂装加工生产线操作调整工岗中实施考核试卷含答案
- 快件派送员岗位安全宣教考核试卷含答案
- 2026年空间设计高级创意专家招聘笔试试卷 招录14人题库
- 2026年生产数据高级治理师招聘笔试试卷 招录12人
- 2026年浙江省临安市高三数学下册期末考试模拟试卷(黄金题型)附答案
- 2026年四川省万源市高三数学下册期末考试模拟测试卷附答案【综合卷】
- 2026届阿里地区日土县四年级数学第二学期期末质量跟踪监视试题(含解析)
- 2026届阳江市阳西县数学四年级下学期期末试题含答案
- 2026届阜新市太平区四下数学期中质量跟踪监视模拟试题含解析
- 2026中国辅助生殖技术服务渗透率提升路径与区域市场差异调查报告
- 2026中国工业互联网安全威胁态势与防护体系建设研究报告
- 2026年秋人教版一年级数学上册第一单元测试卷可打印
- 2026年全国法律硕士(法学)联考真题及答案
- 《人形机器人数据训练场建设规范》
- 招聘84人!2026年青海省检察机关面向社会公开招聘聘用制书记员考试备考试题及答案解析
- 2026慢性病患者老人秋冬防病保健专题培训课件
- 北京市城市协管员笔试题库及答案详解
- SEMI F63-24 中文版 半导体工艺用超纯水标准指南(2024版)
- 2026年广州市中考语文试卷(含答案及解析)
- 《朝花夕拾》名著导读
评论
0/150
提交评论