已阅读5页,还剩53页未读, 继续免费阅读
版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领
文档简介
HB/T 中华人民共和国信息产业部发布-实施-发布家庭主网通讯协议规范Specification for home backbone-network communication protocol (报批稿)SJ/T SJ中华人民共和国电子行业标准ICS 33.040.40L78备案号:1SJ /T目 录前言. II引言.III1 范围.12 规范性引用文件.13 定义和缩略语.13.1 定义.13.2 缩略语 abbreviations.24 家庭主网协议.34.1 家庭主网物理层协议.34.2 家庭主网网络传输层44.3 家庭主网基本应用层通讯协议.45 设备管理46 服务管理47 网络安全.48 IP地址管理.59 位置注册协议与通道建立协议.59.1 位置注册协议LRP.59.2 通道建立协议CCP.810 主网关与子网关通讯协议.910.1 通讯的数据包格式.910.2 通讯过程1211 主网关应用程序接口.1311.1 数字电视中间件系统.1311.2 服务框架.1411.3 框架启动或停止.1611.4 家庭主干网的应用程序接口(API).1611.5 http服务包.4311.6 网关与服务器通讯方式和消息类型.49前 言数字电视接收设备与家庭网络平台接口系列标准由如下标准组成:家庭控制子网通讯协议规范,家庭网络系统体系结构及参考模型,家庭主网通讯协议规范,家庭主网接口一致性测试规范,家庭控制子网接口一致性测试规范,家庭网络设备描述文件规范。本标准由全国音频、视频及多媒体系统与设备标准化技术委员会归口。本标准由中国电子技术标准化研究所总归口。本标准由家庭网络标准工作组负责起草;本标准起草单位:北京长信嘉信息技术有限公司,上海贝岭股份有限公司,深圳数视通数字技术有限公司,上海广电信息产业股份有限公司,杭州智源电子有限公司,无锡小天鹅股份有限公司,联想集团公司,青岛海信集团有限公司,中国电子科技集团公司第五研究所,南京东大移动互联技术有限公司,中国电子技术标准化研究所,中国电子科技集团公司第三研究所,TCL多媒体电子研发中心,北京阜国数字技术有限公司,贵州以太科技公司,上海华虹集成电路有限公司,夏新电子股份有限公司,清华同方股份有限公司,中科院软件研制中心,海尔集团公司,杭州大道科技有限公司,春兰集团公司,四川长虹电器股份有限公司。本标准主要起草人:曹京伟,郭彬,黄泽强,黄则清,胡继红,吉学农,姜珊,刘景华,刘尚文,沈连丰,田晨燕,田玉静,王冰,王钢,徐翔,谢后贤,谢文录,许少波,杨士元,张倪,张汉奇,郑振华,仲伟曦,周均。引 言家庭网络是把家庭范畴里的信息设备、通信设备、娱乐设备、家用电器、水电气热计量表、照明系统和安全系统连接在一起,组成的一种局域网,其主要功能是集中控制各种家用电器并接入互联网,以共享网络信息资源和享受网络服务。家庭网络系统扩展至整幢住宅和整个社区,而成为智能住宅小区和智能社会的基础。信息化家庭是信息化社会的基本单元。家庭网络将成为全球信息基础设施的重要组成部分。家庭信息系统是以家庭网络为中心的智能家庭信息中心平台,它提供面向家庭的多种应用和服务,是通用的系统和软件的应用平台。本标准规定了家庭网络系统中主网的通信协议。 本标准的发布机构提请注意如下事实,声明符合本标准时,可以使用涉及本标准第10章“主网关与子网关通讯协议”有关内容的如下专利a);以及涉及本标准第11章“主网关应用程序接口”有关内容的如下专利b)。 本标准的发布机构对于专利的范围、有效性和验证资料不提出任何看法。专利持有人已向本标准的发布机构保证,他愿意同任何申请人在合理和非歧视的条款和条件下,就使用授权许可证进行谈判。在这方面,该专利持有人的声明已在本标准的发布机构备案。有关资料可从以下地址获得:a) 专利名称:数字家庭网络网关之间的通讯方法;专利权人:北京长信嘉信息技术有限公司;联系人:王钢;地址:北京市海淀区中关村大街四十号当代商城九层。b) 专利名称:控制用户从网络下载软件的方法; 专利权人:上海广电信息产业股份有限公司; 联系人:黄则清;地址:上海市斜土路1646号。 请注意除上述已经识别出的专利外,本标准的某些内容由可能涉及专利。本标准的发布机构不应承担识别这些专利的责任。III家庭主网通讯协议规范1 范围本标准规定了家庭网络系统中主网的通讯协议。本标准适用于家庭或类似的室内场所构建的网络。2 规范性引用文件下列文件中的条款通过本标准的引用而成为本标准的条款。凡是注日期的引用文件,其随后所有的修改单(不包括勘误的内容)或修订版均不适用于本部分,然而,鼓励根据本标准达成协议的各方研究是否使用这些文件的最新版本。凡是不注明日期的引用文件,其最新版本适用于本标准。SJ/T xxxxxxxx 数字电视接收设备中间件功能性能规范SJ/T yyyyyyyy 家庭控制子网通讯协议规范SJ/T zzzz zzzz 家庭网络设备描述规范 IEEE 802.11a 无线局域网媒体访问控制和物理层规范修订1:5GHz频段较高速物理层规范IEEE 802.11b 无线局域网媒体访问控制和物理层规范:2.4GHz频段较高速物理层扩展规范IEEE 802.11g 无线局域网媒体访问控制和物理层规范修订4:2.4GHz较高速物理层进一步扩展规范IETF RFC768 用户数据报文协议IETF RFC791 互联网协议IETF RFC793 传输控制协议IETF RFC1960 LDAP(简单目录访问协议)的搜索过滤器的字符串表示格式IETF RFC2131 动态主机配置协议IETF RFC2254 LDAP(简单目录访问协议)的搜索过滤器的字符串表示格式IETF RFC3082 服务定位协议ISO 639 语言名称代码3 术语、定义和缩略语3.1 术语和定义下列术语和定义适用于本标准。3.1.1家庭网络 home network家庭网络是融合控制网络和多媒体信息网络于一体的家庭信息化平台,是在家庭范围内,实现信息设备、通信设备、娱乐设备、家用电器、自动化设备、照明设备、保安(监控)装置及水电气热表或概称的三表三防、家庭求助报警等设备互联和管理的系统。3.1.2家庭主网 Home main-network家庭主网是家庭网络中包括家庭主网关、信息设备、娱乐设备、通讯设备、家庭控制子网关等设备的网段。3.1.3家庭主网关 home backbone-network gateway家庭主网网关(简称主网关)是家庭主网中的一种设备,主网关能够与家庭主网中的设备实现互联,为各种接入设备提供外部网络接口,实现对家庭主网的配置和管理,同时作为家庭服务器被内部设备和外部网络访问。3.1.4家庭控制子网关 home control sub-network gateway家庭控制子网关(简称子网关)是家庭控制子网中的一种设备。子网关能够与家庭控制子网中的设备实现互联,同时为家庭控制子网内的各种设备提供与家庭主网的接口,使各子网设备可以获得各种服务,并实现对家庭控制子网的配置和管理。注1:子网关在物理实现上可以与家庭主网关成为一体化的设备。注2:子网关具有以下主要功能:a) 提供友好的人机界面;b) 具有管理各种家庭控制子网设备的功能;a)c) 与各个通讯模块进行数据交换。子网关与嵌入到各子网设备中的通讯模块之间的通讯协议遵从SJ/T yyyyyyyy。3.1.5设备注册表 device registration table设备注册表是由子网关保存的描述家庭控制子网中各个家庭控制子网设备信息的文件。3.1.6家庭主网设备 devices in the home backbone network家庭主网设备是指接入家庭主网中具有网络接口、符合家庭主网通讯协议、支持必要网络功能的设备。.8设备描述文件 device description file 设备描述文件是用来描述设备自身功能和命令的数据结构文件。每台家庭控制子网设备都具有一份设备描述文件。该文件描述了设备的各个控制、状态参数,以及对相关参数进行读取与设置的命令、设备控制图形界面、语音提示和报告等内容。设备描述文件的格式遵循SJ/T zzzzzzzz。.10服务框架 framework 服务框架是家庭主网关应用程序接口中提供给应用开发者编写代码的环境。3.2 缩略语 abbreviations下列缩略语适用于本标准。ADSL不对称数字用户线(asymmetrical digital subscriber line)CCP通道建立协议(channel creation protocol)DDF 设备描述文件(device description file)DHCP动态主机地址控制协议(dynamic host control protocol)DHN数字家庭网络(digital homework network)DS 数字签名(digital signatures)FTP 文件传输协议(file transfer protocol)HTML超文本链接标示语言(hypertext markup language)HTTP超文本传送协议(hypertext transfer protocol)ID标识符(identification)IETF因特网工程任务组(internet engineering task force)IP因特网协议(internet protocol)JAR Java 文档(java archive)JVMJAVA虚拟机(java virtual machine)LRP地址注册协议(location registration protocol)MIB 标准设备管理信息库(management information base)NAT 地址转换(net address translation)RTP 实时传输协议(realtime transport protocol)SLP 服务定位协议(service location protocol)SNMP简单网络管理协议(simple network management protocol)SSH 安全访问协议(secure shell)SSL安全接口层(secure socket layer)Telnet 远程登录TLS传输层安全(transport layersecurity)UDCP统一设备控制协议(universal device control protocol)UDS统一设备序列号(univeral devices sequence)UDP用户数据报文协议(user datagram protocol)VDSL 超高速数字用户线(very high data rate digital subscriber line)XML可扩展链接标示语言(extensible markup language)WPL 无线物理层(wireless physical layer)4 家庭主网通讯协议家庭主网通讯协议的分层结构如图1所示。HTTP(支持SSL)FTPTelnetSLPSNMPSMTPLRPCCP其它TCP (RFC 793)UDP (RFC 768)IP ( RFC 791 )GB/T15629.3(IEEE802.3)IEEE 802.11a/b/ga 是指未纳入本标准的,将来作为协议扩充部分的协议图1 家庭主网协议结构4.1 家庭主网物理层协议家庭主网通讯协议的物理层可以采用有线或无线方式,物理层支持的信息最大峰值传输速率应大于10Mbps。采用无线方式时,应遵循无线局域网标准IEEE802.11b、IEEE802.11g或IEEE802.11a协议,物理层支持的信息最大峰值传输速率为11Mbps、22Mbps或54Mbps。采用有线方式时,应遵循GB/T15629.3(IEEE802.3)的规定,物理层支持的信息传输速率为10Mbps /100Mbps。家庭主网关具有与外部网络通讯功能,其与外部网络通讯的物理层接口根据应用有多种选择,但至少应具有下列定义的接口中的一个。4.1.1 家庭主网关有线接口家庭主网网关支持自适应100/10Base-T 接口。100/10Base-T 接口应该满足IEEE 802.3 的要求。100/10Base-T 接口采用8芯双绞线作为物理介质,其中2芯用于发送,2芯用于接收;物理层采用曼切斯特编码,用0.85V和-0.85V分别表示二进制1和0 ,最大长度为100m。4.1.2 家庭主网关无线 接口家庭主网网关IEEE-802.11 接口支持IEEE 802.11b、IEEE 802.11g或IEEE 802.11a协议。4.1.3 家庭主网关ADSL 接口为保证兼容性要求,ADSL接口应满足ITU-T G.992.1 中规定的初始化嵌入操作通道操作信道、开销信道在线适配和再配置协议要求。4.1.4 家庭主网关电缆调制解调器接口该接口应符合电信行业接入网技术要求电缆调制解调器的规定。4.1.5 家庭主网关VDSL接口信息产业部正在制订VDSL接口规范,待相关的标准完成后直接引用。4.2 家庭主网网络传输层家庭主网通讯协议的网络传输层采用TCP/IP协议,且所有家庭主网设备应支持TCP/IP协议。4.3 家庭主网基本应用层通讯协议家庭主网设备可以根据自身功能的不同选择支持不同的应用层协议。家庭主网设备的基本的网络通讯应用采用如下标准协议:Web浏览采用HTTP,文件传输采用FTP,电子邮件采用SMTP,远程登录采用Telnet。以上协议的具体规范参照相应的互联网工程小组(IETF)标准。5 设备管理家庭主网中的设备管理采用简单网络管理协议(SNMP),设备的相关描述、管理信息采用相关设备的标准设备管理信息库(MIB)的格式和方法。对不同设备的MIB内容,采用相关的国际标准,如没有相关设备的标准MIB,需针对该设备制定相应的MIB内容标准。相关设备的MIB内容定义请参照相关文档。通过SNMP可以解决主网设备的自动发现和管理的功能。6 服务管理家庭主网的服务管理采用IETF RFC3082。它为家庭主网设备服务的发现、定位和配置提供了一个可扩展的框架,而无须太多的静态配置和管理。7 网络安全家庭主网关是联系家庭内部和外部的接口,也是保护家庭内部网络安全的屏障。一方面,主网关可以通过对数据包进行过滤而形成保护家庭内部网络的防火墙;另一方面,主网关向外提供Web服务,本标准对其安全机制进行了规定。在家庭主网关对外提供的Web服务中推荐使用加密套接字协议(SSL)。SSL是Netscape公司设计的主要用于Web的安全传输协议。这种协议在Web上获得了广泛的应用。IETF将SSL作了标准化,即RFC2246,并将其称为安全传输协议(transport layer security)。SSL介于HTTP协议与TCP之间,在TCP之上建立了一个加密通道,通过这一层的数据经过加密,达到保密的效果。SSL是一个介于HTTP协议与TCP之间的一个可选层,其在网络分层协议结构中的位置如图2所示。HTTPSSLTCPIP图2 SSL在网络协议中的位置为了进一步增强网络安全,建议在家庭主网关上添加安全访问协议(SSH)。SSH是IETF的网络工作组所制定的一组协议,其目的是在非安全网络上提供安全的远程登录和其他安全网络服务。通过使用SSH,可以把所有传输的数据加密,防止“中间人”的攻击,而且防止DNS欺骗和IP欺骗。同时,使用SSH传输的数据是经过压缩的,可以加快传输的速度。当远程用户通过Internet访问家庭主网关的Web服务器时,采用一次性口令(OTP,One Time Password)的技术来保护用户身份,防止家庭网络遭到恶意攻击。8 IP地址管理家庭主网中的地址分配采用动态主机控制协议(DHCP)。主网关向各个家庭主网设备通过DHCP协议分配IP地址。利用DHCP协议可以使各个家庭主网设备可以实现IP地址自动分配,即插即用。为了减少家庭主网设备对整个IP地址资源分配的压力,降低IP地址管理的复杂程度,家庭主网设备可以动态分配私有IP,主网设备访问Internet通过主网关提供的网络地址转换(NAT)服务实现。9 位置注册协议与通道建立协议家庭主网连接到外部网络时,主网关获得的IP地址可能是由接入服务器自动分配的动态IP地址。该地址不是固定的,这些动态分配IP又可能是:1)有效的公共IP;2)RFC1918限定的私有IP。使用动态IP(无论是公共的还是私有的),使用户远程访问家庭主网关遇到困难:用户必须先设法知道主网关的IP地址才能发起主动的访问。这就要求用户以某种方式了解使用动态IP的主网关当前有效的公共IP地址。主网关被分配的是私有IP时,用户无法直接通过主网关的私有IP访问主网关,需要由为主网关提供接入服务的服务器配合解决远程访问主网关的问题。使用位置注册协议(LRP),辅以通道建立协议(CCP)解决远程访问主网关的问题。9.1 位置注册协议(LRP)地址服务器是公开提供给用户的主网关地址公布服务器,用户可以通过访问地址服务器来获得家庭主网关的有效IP地址。LRP协议用于主网关被分配公共IP地址时,自动通知地址服务器自身的当前IP地址。9.1.1 实现方法 家庭主网关参数每台家庭主网关在出厂时由厂家指定内嵌如下参数:唯一的产品序号UDS,长度为6个字节(UDS的描述和定义参见SJ/T yyyyyyyy);唯一的产品密码,长度不限;缺省的LRP服务器的IP地址或域名(用户可重新配置)。 LRP服务器在相应的LRP服务器上,保存有每台可提供服务的主网关的UDS和密码。使用动态IP的主网关向自己的LRP服务器注册自身当前IP地址,以供客户查询。LRP的基本操作包括家庭主网关发送请求和LRP服务返回应答。其中,发送请求需要包含如下信息:主网关的UDS;主网关当前的IP地址;主网关当前NAT服务器的IP地址(可选);数字签名(DS)。DS是主网关以自己的密码(密码长度无限制)为密钥计算得出的。网关的UDS和密码是一一对应的,主网关和其对应的LRP服务器均有记录,LRP服务器在收到请求后首先重新计算该数字签名,如果与收到的DS不符,则该请求被拒绝。主网关的IP是私有IP时,一定有一个NAT服务器与之对应。NAT的具体规则是由NAT服务器规定的。主网关应同时报告自己当前IP和对应的NAT服务器IP。另外,当LRP服务器的地址变更时,提供一种机制使得用户无须太多的干预就可生效。9.1.2 数据包格式及用法LRP协议的数据包格式如图3所示。协议版本号数据包类型保留位数据包长度数据包内容2 bit4 bit2 bit2 byte142 byte图3 位置注册协议的数据包格式其中:a) 协议版本号:2 bit,表示通讯协议版本,目前为1;b) 保留:2 bit,用于以后的协议扩展;c) 数据包类型:4 bit,用于表示协议数据包的类型,具体定义见表1。表1 网关与LRP服务器通讯的数据包类型数据包类型说明功能0注册网关向LRP服务器注册1,2应答通讯的确认3地址迁移通告LRP服务器地址改变时通知网关4-15预留数据包长度:2个字节,表示该数据包的长度,单位为字节。数据:数据包的内容。 主网关地址注册请求使用动态IP地址的主网关向自己的LRP服务器注册自身当前IP地址时,发送该数据包给LRP服务器,以供客户查询。主网关地址注册请求格式如图4所示。版本 2bit类型 4bit保留 2bit数据包长度 2byte UDS (6 byte)本机IP (4 byte)NAT服务器IP (4 byte)数字签名DS (16 byte)图4 主网关地址注册请求格式其中:a) 版本号:当前值为1;b) 包类型:值为1;c) 保留字段:保留d) UDS:主网关的UDS;e) 本机IP:主网关当前IP;f) NAT服务器IP:当主网关IP为私有IP时,此域为主网关所用的NAT服务器的对外有效IP。当主网关IP为有效公共IP时,此域值应为全零;g) DS:计算出的数字签名。 应答当LRP服务器收到主网关的注册信息时,向主网关发送该数据包,表示确认。当LRP服务器地址迁移后,向在其注册的主网关发送地址迁移通告,主网关确认后发送应答。应答数据包的格式如图5所示。版本2bit类型 4bit保留 2bit数据包长度 2byte本机IP (4 byte)数字签名DS (16 byte)图5 应答数据包的格式其中:a) 版本号:当前值为1;b) 包类型:值为1时表示请求被通过,为2时表示请求被拒绝;c) 保留字段:保留;d) 本机IP:发送该报文的主网关或LRP服务器的IP地址;e) DS:计算出的数字签名。 LRP服务器地址迁移通告当LRP服务器地址迁移后,向在其注册的主网关发送地址迁移通告,主网关确认后发送应答。LRP服务器地址迁移通告格式如图6所示。版本 2bit类型 4bit保留 2 bit数据包长度 2byteLRP 服务器新IP (4 byte)数字签名DS (16 byte)图6 LRP服务器地址迁移通告格式其中:a) 版本号,当前值为1;b) 包类型,值为3;c) 保留字段:保留;d) LRP服务器新IP:LRP服务器的新IP地址;e) DS:计算出的数字签名。LRP服务器的IP地址改变后,原IP地址在停用前应有若干天作为过渡期,在过渡期内新,旧IP地址同时有效。新IP地址启用后,该服务器在原IP地址上接收到地址注册请求时,通过验证并给予服务后,应发给此主网关LRP服务器地址迁移通告以告知新IP地址。主网关在得到迁移通告后应立即更新其配置信息,下一次注册请求开始使用LRP新IP地址。除上述自动机制外,LRP服务器地址迁移消息应通过其它方式发布。主网关如在旧IP地址停用之前始终未曾访问LRP服务器,未自动更新其关于LRP服务器的配置,可以通过手工输入的方式改变配置,使自己可以访问更新了IP地址的LRP服务器。9.1.3 数字签名计算方法LRP数据包中的数字签名是使用消息摘要算法MD5(the MD5 message-digest algorithm RFC1321),对数据包中除DS本身之外的全部内容加上主网关密码进行运算得到的结果。数字签名主要用于身份认证,这有双重含义:LRP服务器认证主网关的身份;主网关认证LRP服务器的身份。每个主网关有自己的密码,对应的LRP服务器没有密码,但了解主网关的密码。因此,在LRP服务器和主网关间一对一的认证过程中,主网关的密码是双方共有的钥匙,即:数字签名中所用的密码为主网关密码。MD5对任意长度的输入得出的输出均为128位(16字节)长,而密码长度不限。 安全性MD5是可靠的(创造出具有相同MD5值的不同信息或从给定MD5值反推原始信息从可计算的角度是不可能的),该协议是安全的。9.1.4 底层传输协议LRP使用TCP作为传输层协议,使用的TCP端口号为1990。9.2 通道建立协议通道建立协议(CCP)规定主网关使用私有IP提供服务的方法。现有的网络地址转换(NAT )的实现是由内部主机向外发起连接从而建立IP地址映射,CCP的目的就是要实现反向操作。所谓“通道”,就是指私有传输层地址(IP加端口号)和公共传输层地址的映射关系。外部的主机可以使用已经建立映射的公共传输层地址,透明地主动连接到内部的私有传输层地址上。9.2.1 协议流程为了访问使用私有IP的主网关,在外部网络中的客户机要先从另一台服务器处取得相应的IP地址和端口号。这台提供访问信息的服务器被称为“CCP服务器”。客户通过位置注册协议LRP可以获得主网关私有IP和对应的NAT服务器的IP地址。NAT服务器必须支持CCP协议,并作为CCP服务器。客户机向CCP服务器查询时只须提供待查主网关的私有IP。当支持CCP协议的NAT服务器接到“通道建立请求”报文后,为目的主网关建立传输层地址映射并返回结果。9.2.2 CCP协议数据包及用法CCP的数据包分为如下两类:通道建立请求;通道建立应答。 通道建立请求为访问使用私有IP的主网关,在外部网络中的客户机要向CCP服务器发送此数据包,来取得主网关相应的可供访问的IP地址和端口号。CCP服务器的IP地址可以通过LRP协议获得,CCP服务器IP地址就是对应主网关的NAT服务器IP地址。通道建立请求的格式如图7所示。版本(4 bit)类型(4 bit)协议(1 byte)端口号(2 byte)私有IP(Pri-IP) (4 byte)图7 通道建立请求的格式其中:a) 版本号:当前值为1;b) 包类型:值为1;c) 协议:要求建立的传输层地址所使用的传输层协议,0表示TCP,1表示UDP;d) 端口号:建立通道中的私有传输层地址所使用的端口;e) 私有IP(Pri-IP):建立通道中的私有传输层地址所使用的IP地址。 通道建立应答CCP服务器接收到客户对主网关的通道建立请求后,为所请求的传输层通讯建立对应的通道,并返回通道映射描述。通道建立应答的格式如图8所示。版本(4 bit)类型(4 bit)协议(1 byte)私有端口Pri-port(2 byte)私有IP Pri-IP (4 byte)公共IP Pub-IP (4 byte)公共端口Pub-port (2 byte)图8 通道建立应答的格式其中:a) 版本号:当前值为1;b) 包类型:如值为3,则表示返回的结果有效,如值为4,则表示返回的结果无效;c) 协议:要求建立的传输层地址所使用的传输层协议,0表示TCP,1表示UDP;d) 私有端口号:建立通道中的私有传输层地址所使用的端口;e) 私有IP:建立通道中的私有传输层地址所使用的IP地址;f) 公共端口:建立通道中的公有传输层地址所使用的端口;g) 公共IP:建立通道中的公有传输层地址所使用的IP地址。如果映射不能成功,则类型为4,Pub-port和Pub-IP可以为任意值。9.2.3 通道保持时间由于NAT服务器拥有的合法传输层地址是有限的资源,需要服务于许多对象,因此提供私有传输层地址的映射只能是暂时的。NAT服务器在按CCP请求建立了一个传输层地址映射后,如果一段时间内没有接收到以此地址为目的端的任何数据包,则应该将此映射通道撤消,收回该合法传输层地址以备它用。这个超时时间推荐为3s。9.2.4 底层传输协议CCP使用TCP作为传输层协议,使用TCP的端口号为1991。10 主网关与子网关通讯协议用户通过Internet登录主网关,访问并控制家庭主网中的各种设备。家庭控制子网关作为主网中的一个设备,与主网关通讯,向主网关提供家庭控制子网设备的状态,主网关通过子网关控制子网设备。子网关作为主网中的一个设备,需支持DHCP协议(RFC2131),主网关也需支持DHCP协议。子网关作为DHCP的客户端与主网关上的DHCP服务端通讯,自动获得IP地址。主网关和子网关之间的通讯协议是基于TCP的应用协议,其端口号为1088。子网关作为家庭控制子网在主网中的通讯接口,只接受主网关的通讯请求,本协议规定了主网关在子网关的注册功能,子网关只响应已注册的主网关的通讯请求,保证家庭控制子网设备只能被授权的主网关访问。10.1 通讯的数据包格式通讯数据包的格式如图9所示。协议版本号保留数据包类型数据包长度主网编号数据2 bit2 bit4 bit2 byte2 byte0-512K byte帧头帧数据图9 通讯协议数据包格式其中:a) 协议版本号:2bit,表示通讯协议版本,目前为1;b) 保留:2bit,用于以后的协议扩展;c) 数据包类型:4位,用于表示协议数据包的类型,具体定义参见表2;d) 数据包长度:2个字节,表示该数据包不包括帧头在内的帧数据的长度,单位为8 个字节;e) 主网编号:2个字节,由主网关随机选定,在主网关向子网关注册后的主网关与子网关通讯过程中,用于确认主网关的身份;f) 数据:数据包中的内容。表2 主网与子网通讯协议数据包类型数据包类型说明功能0注册主网关向子网关注册1注销主网关向子网关注销2设置主网关向子网的设置参数3读取主网关读取子网的参数4汇报子网关向主网关汇报参数5上传子网关向主网关发送控制子网设备文件或注册表6确认通讯的确认7-15预留10.1.1 注册注册数据包格式如图10所示。数据包类型数据包的内容0主网关的IP6 byte主网编号2 byte 图10 注册数据包格式 该数据包是由主网关发送给子网关的注册数据包,子网关接收到请求并确认后,在以后的通讯中,子网关只接受来自主网关IP地址和主网编号与首次注册一致的主网关的通讯请求。主网编号由主网关随机选择,一旦选定,在主网关注册后的下一次注销前有效。重新注册时,主网编号可重新随机选择。IP地址采用6个字节是为了适应未来IPV6的需要,目前是4个字节的IPV4地址。10.1.2 注销 注销数据包格式如图11所示。数据包类型数据包的内容1主网关的IP6 byte主网编号2 byte 图11 注销数据包格式在主网关关闭,或更换主网关时,注销数据包由主网关发送给子网关。在收到该数据包,并确认主网编号、主网关IP正确的情况下,给出确认数据包。在注销生效后,主网编号同时失效,下一次注册时,重新选择主网编号。10.1.3 设置设置数据包格式如图12所示。数据包类型数据包的内容2要设置的设备的UDS 6 byte设置命令个数1 byte对应的设备文件的设置命令32 byte对应的设备的设置命令32 byte对应的设备的设置命令32 byte图12设置数据包格式该数据包由主网关发送给子网关,用于控制子网设备的参数。其中包括:对应的子网设备标识(UDS)和对应的设置命令,此命令由该设备的设备描述文件确定。一个设置命令数据包可同时设置同一个设备的多个参数,参数的个数用1个字节标明,即一个设置命令数据包最多同时可设置255个参数。每个参数设置命令不长于32个字节。子网关接收到该命令后,通过家庭控制子网进行对应的操作,并返回给主网关操作成功与否的确认。10.1.4 读取读取数据包格式如图13所示。数据包类型数据包的内容3要读取的设备的UDS 6 byte读取命令个数1 byte对应的设备文件的读取命令32 byte对应的设备的读取命令32 byte对应的设备的读取命令32 byte图13 读取数据包格式该数据包由主网关发送给子网关,用于读取家庭控制子网设备的参数。其中包括:对应的子网设备标识(UDS)和对应的读取命令,此命令由设备描述文件说明。一个读取命令数据包可同时读取同一个设备的多个参数,参数的个数由1个字节说明,即一个读取命令数据包最多同时可读取255个参数。每个参数读取命令不长于32个字节。子网关在接收到该数据包后,通过家庭控制子网进行相应的操作,读取的参数以汇报数据包发送给主网关。10.1.5 汇报汇报数据包格式如图14所示。数据包类型数据包的内容4所汇报的设备的UDS 6 byte汇报参数的个数1 byte对应的设备文件的参数32 byte对应的设备文件的参数32 byte对应的设备文件的参数32 byte图14汇报数据包格式该数据包由子网关发送给主网关,用于提供其要读取的子网设备的参数。其中包括:对应的子网设备标识(UDS)和要汇报的参数以及各种异常信息,参数由家庭控制子网设备的设备描述文件说明。一个汇报数据包可同时汇报一个设备的多个参数,参数的个数由1个字节说明,即一个汇报命令数据包最多同时可汇报255个参数,每个参数不长于32个字节。10.1.6 上传上传数据包格式如图15所示。数据包类型数据包的内容5要上传设备的UDS 6 byte对应的设备描述文件或设备注册表图15 上载数据包格式该数据包由子网关发送给主网关,用于提供控制子网设备的设备描述文件或设备注册表。设备描述文件和设备注册表由数据包中的设备UDS区分,如果UDS是子网关的UDS,则上传设备注册表,如果是其它设备的UDS,则上传该设备的设备描述文件。主网关在接收到设备注册表或设备描述文件后,进行设备描述文件与网页的转换和自身的设备管理表格的维护。10.1.7 确认 确认数据包格式如图16所示。数据包类型数据包的内容6确认类型1 byte数据内容1 byte图16 确认数据包格式该数据包用于上述注册、注销、设置、读取等数据包的接收者对所接收到数据包的确认处理。具体定义见表3。表32确认帧的类型说明确认类型数据内容说明0011 byte的数据00表示注册成功11表示注册失败1111 byte的数据00表示注销成功11表示注销失败2211 byte的数据00表示设置成功11表示设置失败3311 byte的数据00表示读取成功11表示读取失败4-4-25511 byte的数据预留10.2 通讯过程家庭控制子网关通过DHCP协议从主网关获得IP地址。 主网关如果需要与子网关通讯,进而控制家庭控制子网中的设备,需要注册到子网关上。一旦注册到子网关上,子网关只与注册的主网关通讯,不接受其它主网设备的通讯请求。 注册的过程由主网关发起。主网关发送注册命令数据包,其中包括主网关的IP地址,以及由主网关随机生成的2个字节的主网编号,子网关接收到该命令并发送确认后,则注册成功。在注册成功后,所有通讯数据包中的主网关编号则为子网关和主网关确认对方身份的标识,子网关只接受来自主网关IP地址且主网编号正确的数据包的请求。 在主网关关闭前,由主网关发起注销请求,如果得到子网关确认,在下次注册前,子网关不接受任何主网关的请求。 主网关与子网关之间的通讯主要是传递家庭控制子网设备的状态等。主网关通过设置、读取命令从子网关读取或设置各个设备的状态参数。子网关通过汇报命令向主网关提供各个设备的设备描述文件、状态参数、设备注册表等内容,使主网关了解整个家庭控制子网的状态。 由于本通讯协议运行在可靠的TCP传输基础上,其传输的可靠性能够得到保证,本协议的确认功能用于描述注册、注销、设置、读取等操作的成功或失败,而不描述传输本身的正确性。11 主网关应用程序接口为了今后应用的扩展以及应用程序的共享,主网关必须具有统一的应用程序接口。这样可以保证不同厂家开发的应用程序可以在统一的软件平台上运行,与硬件平台无关。参照数字电视接收设备中间件功能性能规范,本标准提出了与数字电视中间件标准互补的主网关应用程序接口。11.1 数字电视中间件系统11.1.1 数字电视中间件系统软件功能数字电视中间件系统软件的功能包括以下几个方面:a) 接收和处理不同来源和传输形式的码流;b) 执行各种命令和传递各种事件;c) 记录数据和读写文件;d) 获取硬件资源。11.1.2 数字电视中间件系统软件结构中间件系统的设计应是一种层次型架构,由几个系统模块组成,如图17所示。中间件系统中包括:a) 交互式应用;b) 软件界面;c) 系统移植接口。图17 中间件系统的组成框图11.1.3 数字电视中间件系统模块功能图中各模块的主要功能描述如下:a) 驱动层(driver layer):本模块提供MPEG-2表格数据提取、条件接收和Smart卡控制、信道参数设定、音/视频流控制、Modem管理、TV/VCR控制及其它功能;b) 核心系统模块(Core System):由一系列模块组成,包括内存管理、线程调控、事件管理、安全性控制、数据下载管理及网络协议管理(TCP/ZIP、PPP、HTTP)管理等;c) 图象与多媒体模块(Graphics & AV system):本模块具有与下层平台的接口,提供用于绘图、多视窗管理及音/视频控制的高级函数;d) SI引擎(SI engine):本模块用于管理SI数据库,负责提取EIT、PMT等常用SI表格数据,并且具有监察功能,可提供频道搜寻时已储存的数据,如频道名称等(这里的SI具体是指softimage,即“软”图象, 低对比度图象);e) Java虚拟机(JVM):本模块用来解释执行Java应用程序,并提供Java Debug等功能;f) 网页解析引擎(Presentation engine):支持HTML4.0、XHTML、DOM、CSS等,可显示HTML网页,提供上网功能;g) 应用程序标准接口(Java APIs):包含多个Java程序包,用于开发交互式应用软件。包括一些J2ME的程序包和一系列用于数字电视的专用程序包,如图形显示、多媒体控制、SI数据装载和存取、回路控制及系统资源管理等。此外还提供控制Web浏览器运行Java Applet的程序包;h) 交互式应用程序(Interactive applications):该应用程序并不属于中间件系统,它建立在中间件系统标准界面之上。但在中间件系统提供给用户的同时,也会提供用于协调各种交互式应用程序的内置应用控制器(Application Manager);本规范中定义的家庭主网关应用程序接口是完成图中第一和第三两个模块的功能,将在本规范的12.2节到12.5节做详细的说明,而其它模块功能符合SJ/T xxxxxxxx。11.2 服务框架服务框架是为应用开发商提供针对资源有限的设备编写代码的环境。在这个环境中,动态地调入或调出应用程序,在空闲时更新应用程序,并且通过结构化和可靠的方法与其它应用程序通讯。11.2.1 服务框架目的服务框架的主要目的是提供环境来支持:a)
温馨提示
- 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
- 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
- 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
- 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
- 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
- 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
- 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。
最新文档
- 2025-2026学年大班淘宝活动说课稿
- 甘肃省兰州市永登县2024-2025学年三年级上学期语文期中考试试卷(含答案)
- 2026年甘肃省武威市公务员人员招聘笔试模拟试题及答案详解
- 2025年连云港市连云区公务员人员招聘考试试题及答案详解
- 2026年云南省昭通市公务员人员招聘笔试参考题库及答案详解
- 2026年无锡市惠山区公务员人员招聘笔试备考题库及答案详解
- 2025-2026学年刺勒歌说课稿及反思
- 2026年衡阳市雁峰区公务员人员招聘考试备考题库及答案详解
- 2026年白银市白银区事业单位人员招聘笔试备考试题及答案详解
- 2026年保定市南市区公务员人员招聘笔试参考题库及答案详解
- 2026年昆明市嵩明润泽水务运营有限公司招聘(5人)笔试备考试题及答案解析
- 2026慈溪市上林人才服务有限公司派遣至浒山街道办事处招聘编外工作人员5人考试备考题库及答案详解
- (2026版)围手术期出凝血管理麻醉专家意见
- 建筑工程疫情防控工作方案
- 电力工程预结算工作流程及审计要点
- 2025年内外贸协同发展项目可行性研究报告
- 综合办公室主任岗位竞聘
- 自考03450公共部门人力资源管理模拟试题及答案
- 化工岗位安全操作规程
- 绿色食品品牌2025年建设规划与消费者偏好研究报告
- 膀胱输尿管反流课件
评论
0/150
提交评论