多协议标记交换技术MPLS_第1页
多协议标记交换技术MPLS_第2页
多协议标记交换技术MPLS_第3页
多协议标记交换技术MPLS_第4页
多协议标记交换技术MPLS_第5页
已阅读5页,还剩34页未读, 继续免费阅读

下载本文档

版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领

文档简介

第九章多协议标记交换技术MPLSResourceIETFMultiprotocolLabelSwitching(mpls)WorkingGroup/html.charters/mpls-charter.htmlE.Rosen,A.Viswanathan,R.Callon,MultiprotocolLabelSwitchingArchitecture,RFC3031,January2001L.Andersson,P.Doolan,etal.,LDPSpecification,RFC3036,January2001B.Jamoussi,L.Andersson,etal.,Constraint-BasedLSPSetupusingLDP,RFC3212,January2002内容传统IP转发MPLS概述MPLS体系结构标记分发MPLS与虚电路交换内容传统IP转发MPLS概述MPLS体系结构标记分发MPLS与虚电路交换IP转发概述通过路由协议散发路由信息基于目的地址的转发在每跳节点上执行路由查找算法前缀最长匹配IP转发中的性能问题在每跳节点上执行基于目的地址的路由查找算法(最长前缀匹配)每个路由器可能需要所有Internet上的路由信息

(超过100,000条路由).Update:/8Update:/8RoutinglookupRoutinglookupRoutinglookupIP转发中的流量工程(TrafficEngineering)问题站点A和站点B之间大部分的流量仅使用primarylink基于目的地址的路由算法不能提供在不同路径之间的任何负载均衡(loadbalancing)机制基于策略的路由算法能够使用其它的参数来转发分组,但是存在着可扩展性问题Primary

10GbpslinkLargeSiteALargeSiteBSmallSiteCBackup

2Gbpslink内容传统IP转发MPLS概述MPLS体系结构标记分发MPLS与虚电路交换MPLS基本原理MPLS是一种基于标记(Label)的分组转发机制标记长度短(20比特)且固定标记不仅与IP目的网络对应(与传统IP转发相同),还可与其它的参数,例如QoS或者源地址等MPLS支持转发除IP之外的其它协议MPLS概念FEC:ForwardEquivalenceClass,转发等价类

IPa

5

IPb5

IPc15LER:LabelEdgeRouter,标记边缘路由器LER:LabelEdgeRouter,标记边缘路由器LSR:LabelSwitchingRouter,标记交换路由器1535输入端口输入标记输出端口输出标记1523315223LFIB:LabelForwardingInformationBase标记转发信息表LSP:LabelSwitchedPath,标记交换路径MPLS交换过程只有边缘标记交换路由器(LER)执行路由查找,给分组分配标记其它标记交换路由器(LSR)仅基于标记来交换分组L=5L=3Routinglookupandlabelassignment10.1.0.0/16

L=5LabelswappingL=5L=3LabelremovalandroutinglookupL=3入口LERLSR出口LER/16MPLS交换操作:PUSHL=5输入端口目的网络输出端口输出标记1/16253/16215入口LERLSR出口LER/16MPLS交换操作:SWAPL=5入口LERLSR出口LER/16输入端口输入标记输出端口输出标记1523315223L=3MPLS交换操作:POP入口LERLSR出口LER/16输入端口输入标记输出端口输出标记2310(POP)323412L=3MPLS中的流量工程基于其它参数(QoS、源地址等)将分组分为不同的FEC,并且分配不同的标记,从而选择不同的LSP实现不同路径上的负载均衡Primary

10GbpslinkLargeSiteALargeSiteBSmallSiteCBackup

2Gbpslink5153MPLS封装包含在已有的链路层头标中定义新的MPLS头标LabelATM信元头标HECDATACLPTYPEVCIGFCVPILabelHeaderPPPHeaderLayer3HeaderPPP头标(PacketoverSONET/SDH)LabelHeaderMACHeaderLayer3HeaderLANMACLabelHeaderMPLS头标(SHIM头标)MPLS头标长度为32比特20-bitlabelfield3-bitexperimentalfield1-bitbottom-of-stackindicator8-bittime-to-live(TTL)fieldLABELEXPSTTL0192223312024MPLS标记栈(LabelStack)2层头标中的协议标示符(PID:Protocol

IDentifier)指示在IP头标或者其它第三层头标位于MPLS标记之后Bottom-of-stackbit指示下一头标是标记还是第三层头标LSR仅处理最顶层的标记FrameHeaderLabel1IPHeaderPayloadLabel2Label3S=0S=0S=1PID=MPLS-IP内容传统IP转发MPLS概述MPLS体系结构标记分发MPLS与虚电路交换MPLS体系结构OSPF:OpenShortestPathFirst,开放最短路径优先协议LDP:LabelDistributionProtocol,标记分发协议路由器的功能分为两个主要部分:控制面(controlplane)和数据面(dataplane)DataPlaneControlPlaneOSPF:10.1.0.0/16LDP:10.1.0.0/16Label17OSPFLDPLFIBLDP:10.1.0.0/16Label4OSPF:10.1.0.0/16417LabeledpacketLabel4LabeledpacketLabel17@CISCOSystemsMPLS主要有两个组件:控制面—交换第三层路由信息和标记数据面—基于标记转发分组控制面通过路由协议,例如OSPF,EIGRP(EnhancedInteriorGatewayRoutingProtocol),IS-IS(IntermediateSystem-to-IntermediateSystem),和BGP等来交换路由信息,通过LDP、RSVP、BGP等来交换标记数据面实现一个简单的转发引擎控制面维护标记转发信息表(LFIB).说明LSR:转发标记分组,执行标记交换(LabelSwapping)LER:标记IP分组,并且将其转发到MPLS域,或者去除分组中的标记,将其转发到MPLS域外MPLSDomainLERLSRL=3L=5L=43L=31标记交换路由器LSRATMLSR:仅能转发信元ATMLER:将分组分解成信元,并且将其转发到MPLSATM域,或者将信元组装成分组并且将其转发到MPLSATM域外MPLSDomainATMLERATMLSRL=1/3L=1/6L=1/3L=1/3L=1/5L=1/5L=1/5L=1/6L=1/6L=1/9L=1/9L=1/9ATM标记交换路由器LSRLSR:所有类型的LSR都执行:交换路由信息交换标记转发分组(LSR和LER)或者信元

(ATMLSR和ATMLER)前面两点是控制面功能,最后一点是数据面功能LSR体系结构LSR结构LSR主要转发标记分组或者信元

(ATMLSR).LSRControlPlaneDataPlaneRoutingProtocolLabelDistributionProtocolLabelForwardingTableIPRoutingTableExchangeofroutinginformationExchangeoflabelsIncominglabeledpacketsOutgoinglabeledpacketsLER结构EdgeLSRControlPlaneDataPlaneRoutingProtocolLabelDistributionProtocolLabelForwardingTableIPRoutingTableExchangeofroutinginformationExchangeoflabelsIncominglabeledpacketsOutgoinglabeledpacketsIPForwardingTableIncomingIPpacketsOutgoingIPpacketsMPLS操作–Re-Cap1a.路由协议(例如OSPF,IS-IS)建立到目标网络的路由

1b.标记分发协议

(LDP:LabelDistributionProtocol)建立到目标网络的标记映射

2.入口LER接收分组,执行L3增值服务,并且标记分组3.LSR使用标记交换转发分组4.出口LER删除相应的标记后发送分组内容传统IP转发MPLS概述MPLS体系结构标记分发MPLS与虚电路交换标记分发标记具有局部意义标记分发在相邻节点之间进行,一般是由下游LSR给上游LSR分配标记和FEC的绑定关系分组转发方向上游LSR下游LSRLabel<->FEC标记分发协议基于已有协议扩展标记分发功能RSVP:RSVP-TE(TrafficEngineering)BGP:MPLS-BGP定义新的标记分发协议LDP:LabelDistributionProtocolCR-LDP:Constrained-basedRoutedLDP扩展LDP满足流量工程需求,支持建立具有约束(显示路由约束、QoS约束)的标记交换路径(LSP)标记分发方法UnsolicitedDownstream(MPLS-BGP、LDP)Downstream-on-Demand(RSVP-TE)下游节点向上游节点主动公告标记分组转发方向上游节点向下游节点请求标记LSR1LSR2Label<->FEC分组转发方向LSR1LSR2Label<->FECFEC<->?标记分发协议LDP:报文发现消息(DiscoveryMessage)通告和维护网络中某个LSR的存在会话消息(SessionMessage)建立、维护和中止两个相邻LSR交换标记/FEC绑定信息的会话公告消息(AdvertisementMessage)建立、修改和删除标记/FEC绑定通知消息(NotificationMessage)提供错误信息等UDPTCP标记分发协议LDP:过程目的网络输出端口/162/163输入端口输入标记输出端口输出标记1-2153-212标记15,目的网络/16目的网络输出端口/162/162/16/16输入端口输入标记输出端口输出标记1152611238标记只需在节点范围内唯一标记6,目的网络/16路由表标记转发信息表123231公告消息公告消息RSVP-TEPATH消息中包含了标记请求RESV消息中包含了下游节点给上游节点分配的标记LER1LER1PATH消息(LABEL-REQUEST)RESV消息(LABEL)MPLS中的循环检测MPLS头标中的TTL域的功能与IP头标中的TTL相同,用于防止分组在网络中出现循环在入口LER,通常将分组的TTL从IP头标拷贝到标记头标中,每经过一跳LSR标记头标中的TTL减一对于MPLS中不能对TTL值减一的LSP段,根据网络拓扑结构推算出分组将要经过的节点数,然后从TTL中减去当TTL减为0时,分组将被丢弃

MPLSDomainTTL操作入口LER:TTL从IP头标拷贝到标记头标出口LER:TTL从标记头标拷

温馨提示

  • 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
  • 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
  • 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
  • 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
  • 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
  • 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
  • 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。

评论

0/150

提交评论