北邮第一讲计算机网络概述_第1页
北邮第一讲计算机网络概述_第2页
北邮第一讲计算机网络概述_第3页
北邮第一讲计算机网络概述_第4页
北邮第一讲计算机网络概述_第5页
已阅读5页,还剩70页未读, 继续免费阅读

下载本文档

版权说明:本文档由用户提供并上传,收益归属内容提供方,若内容存在侵权,请进行举报或认领

文档简介

1、 计算机通信与网络 信息与通信工程学院 张 彬 2013年3月 计算机网络概述计算机网络概述 协议与体系结构协议与体系结构 物理层物理层 数据链路层数据链路层 信道共享技术信道共享技术局域网局域网广域网广域网(网络层网络层) 网络互联网络互联(IP及其配套协议及其配套协议)传输层传输层(TCP、UDP) 应用层应用层 要点要点:q计算机网络的概念计算机网络的概念q计算机网络的发展过程计算机网络的发展过程q通信子网和资源子网的概念通信子网和资源子网的概念q三种交换方式三种交换方式qInternet的发展的发展qOSI/RM与与TCP/IP的体系结构的体系结构q标准及其标准组织标准及其标准组织q计

2、算机网络的分类计算机网络的分类q有关三网融合有关三网融合q网络的拓扑网络的拓扑q计算机网络的主要性能指标计算机网络的主要性能指标计算机网络计算机网络: 利用通信设备和线路将地理位置不同、利用通信设备和线路将地理位置不同、自主的自主的多个计算机系统多个计算机系统互连互连起来,以功能完起来,以功能完善的网络软件实现网络中资源共享和信息传善的网络软件实现网络中资源共享和信息传递的系统。递的系统。自主的自主的: autonomous互连互连: interconnect面向终端的的计算机网络,各终端通面向终端的的计算机网络,各终端通过通信线路共享主机的硬件和软件资过通信线路共享主机的硬件和软件资源源以通

3、信子网为中心,用户通过分组交以通信子网为中心,用户通过分组交换网可共享用户资源子网的硬件和软换网可共享用户资源子网的硬件和软件资源件资源采用标准的分层体系结构采用标准的分层体系结构H: Host 主机主机 T:终端终端 M:调制解调器调制解调器线路控制器线路控制器: 负责计算机和线路的通信,主要完成串行和并行传负责计算机和线路的通信,主要完成串行和并行传 输的转换和简单的差错控制。输的转换和简单的差错控制。HostTLine controllerMM多重线路控制器多重线路控制器: 控制多条电路,主机负责每条控制多条电路,主机负责每条 线路的收发线路的收发;通过拨号,多个终端可同时上到主机上。通

4、过拨号,多个终端可同时上到主机上。HostTMultiline controllerMMMMMMTTPSTNHostTFront End ProcessorMMMMMMTTPSTNFEP 为了节省通信费用,可在远程终端密集处加一个集为了节省通信费用,可在远程终端密集处加一个集中器。集中器的一端用多条低速线路与各个终端相连,中器。集中器的一端用多条低速线路与各个终端相连,其另一端则用一条较高速率的线路和计算机相连。由于其另一端则用一条较高速率的线路和计算机相连。由于集中器不是简单的多路复用器而是一个智能复用器,它集中器不是简单的多路复用器而是一个智能复用器,它可利用一些终端的空闲时间来传送其他处

5、于工作状态的可利用一些终端的空闲时间来传送其他处于工作状态的终端的数据。终端的数据。HostTFront End ProcessorMMMMTTPSTNFEPconcentratorl60 年代初,美国国防部领导的远景研究规划局年代初,美国国防部领导的远景研究规划局ARPA (Advanced Research Project Agency) 提出提出要研制一种生存性要研制一种生存性(survivability)很强的网络。很强的网络。l传统的电路交换传统的电路交换(circuit switching)的电信网有一的电信网有一个缺点:正在通信的电路中有一个交换机或有一个缺点:正在通信的电路中有

6、一个交换机或有一条链路被炸毁,则整个通信电路就要中断。条链路被炸毁,则整个通信电路就要中断。l如要改用其他迂回电路,必须重新拨号建立连接。如要改用其他迂回电路,必须重新拨号建立连接。这将要延误一些时间。这将要延误一些时间。 计算机网络的产生背景计算机网络的产生背景l网络用于计算机之间的数据传送,而不是为了网络用于计算机之间的数据传送,而不是为了打电话。打电话。l网络能够连接不同类型的计算机,不局限于单网络能够连接不同类型的计算机,不局限于单一类型的计算机。一类型的计算机。l所有的网络结点都同等重要,因而大大提高网所有的网络结点都同等重要,因而大大提高网络的生存性。络的生存性。l计算机在进行通信

7、时,必须有冗余的路由。计算机在进行通信时,必须有冗余的路由。l网络的结构应当尽可能地简单,同时还能够非网络的结构应当尽可能地简单,同时还能够非常可靠地传送数据。常可靠地传送数据。 l两部电话机只需要用一对电线就能够互两部电话机只需要用一对电线就能够互相连接起来。相连接起来。 l5 部电话机两两相连,需部电话机两两相连,需 10 对电线。对电线。lN 部电话机两两相连,需部电话机两两相连,需 N(N 1)/2对电线。对电线。l当电话机的数量很大时,这种连接方法需要的电线当电话机的数量很大时,这种连接方法需要的电线对的数量与电话机数的平方成正比。对的数量与电话机数的平方成正比。 l当电话机的数量增

8、多时,就要使用交换当电话机的数量增多时,就要使用交换机来完成全网的交换任务。机来完成全网的交换任务。 交换机l在这里,在这里,“交换交换”(switching)的含义是:的含义是:转接转接把一条电话线转接到另一条电话线,把一条电话线转接到另一条电话线,使它们连通起来。使它们连通起来。l从通信资源的分配角度来看,从通信资源的分配角度来看,“交换交换”就是按照某种方式就是按照某种方式动态地分配动态地分配传输线路传输线路的资源。的资源。 l电路交换必定是面向连接的。电路交换必定是面向连接的。 l电路交换的三个阶段:电路交换的三个阶段:建立连接建立连接通信通信释放连接释放连接电路交换举例nA 和 B

9、通话经过四个交换机n通话在 A 到 B 的连接上进行交换机交换机交换机交换机用户线用户线中继线中继线BDCA电路交换举例nC 和 D 通话只经过一个本地交换机n通话在 C 到 D 的连接上进行交换机交换机交换机交换机用户线用户线中继线中继线BDCAl计算机数据具有突发性。计算机数据具有突发性。l这导致通信线路的利用率很低。这导致通信线路的利用率很低。主机终端以主机为中心以分组交换网为中心主机分组交换网通信子网通信子网: 负责计算机网络中的信息传递。由网络节点负责计算机网络中的信息传递。由网络节点IMP(Interface message Processor)和通信链路组成,将主机、和通信链路组

10、成,将主机、终端连在一起的部分。终端连在一起的部分。资源子网资源子网: 负责信息处理,由主机和终端构成。负责信息处理,由主机和终端构成。 主机主机:网络中的设备,运行用户程序的机器网络中的设备,运行用户程序的机器。HostIMPHostTHostCommunication subnetResource subnetIMP(Interface message Processor)报文报文l在发送端,先把较长的报文在发送端,先把较长的报文划分成较短划分成较短的、固定长度的数据段的、固定长度的数据段。 1101000110101010110101011100010011010010假定这个报文较长不

11、便于传输数 据数 据数 据报文l每一个数据段前面添加上每一个数据段前面添加上首部首部构成分组。构成分组。首部首部首部分组 1分组 2分组 3请注意:现在左边是“前面”l分组交换网以分组交换网以“分组分组”作为数据传输单元。作为数据传输单元。l依次依次把各分组发送到接收端(假定接收端把各分组发送到接收端(假定接收端在左边)。在左边)。数 据首部分组 1数 据首部分组 2数 据首部分组 3l每一个每一个分组的首部都含有分组的首部都含有地址地址等控制信等控制信息。息。l分组交换网中的结点交换机根据收到的分组交换网中的结点交换机根据收到的分组的首部中的分组的首部中的地址信息地址信息,把分组,把分组转发

12、转发到下一个结点交换机。到下一个结点交换机。l用这样的用这样的存储转发存储转发方式,最后分组就能方式,最后分组就能到达到达最终目的地最终目的地。l接收端收到分组后剥去首部还原成报文。接收端收到分组后剥去首部还原成报文。数 据首部分组 1数 据首部分组 2数 据首部分组 3收到的数据数 据数 据数 据l最后,在接收端把收到的数据最后,在接收端把收到的数据恢复成为恢复成为原来的报文原来的报文。l这里我们假定分组在传输过程中没有出这里我们假定分组在传输过程中没有出现差错,在转发时也没有被丢弃。现差错,在转发时也没有被丢弃。报文1101000110101010110101011100010011010

13、010分组交换网的示意图H1A分组交换网BDECH5H6H4H2H3H1 向 H5 发送分组H2 向 H6 发送分组注意分组路径的变化!结点交换机主机注意分组的存储转发过程H1A分组交换网BDECH5H6H4H2H3H1 向 H5 发送分组结点交换机主机在结点交换机 A 暂存查找转发表找到转发的端口在结点交换机 C 暂存查找转发表找到转发的端口在结点交换机 E 暂存查找转发表找到转发的端口最后到达目的主机 H5 电路交换电路交换 :电话系统,通信前先建立连接,预先分配资源电话系统,通信前先建立连接,预先分配资源 报文交换报文交换 :邮政系统,存储转发方式,动态分配资源,邮政系统,存储转发方式,

14、动态分配资源,数据传送的单位是较长的报文数据传送的单位是较长的报文(message) 分组交换分组交换 :存储转发方式,动态分配资源,数据传送的存储转发方式,动态分配资源,数据传送的单位是较短的分组单位是较短的分组(packet,包)包) A P1P2P3P4 P1P2P3P4 P1P2P3P4BCD分组交换分组交换报文交换报文交换报文报文报文ABCDABCD报文t呼呼叫叫阶阶段段数数据据传传送送电路交换电路交换连连接接释释放放三种交换的比较 P1P2P3P4P1P2P3P4P3P4报文报文报文A B C D A B C DA B C D报文交换电路交换分组交换t连接建立数据传送报文P2P1连

15、接释放数据传送的特点比特流直达终点报文报文报文分组 分组 分组存储转发存储转发存储转发存储转发1 接续时间接续时间: 电路交换电路交换: 拨号时间相对长拨号时间相对长 报文交换报文交换: 发送用户不需建立端到端的连接,发送用户不需建立端到端的连接, 接通本地交换机的时间小于接通本地交换机的时间小于1秒。秒。 分组交换分组交换: 面向连接面向连接:100ms 无连接无连接2 传播时延传播时延: 是指电磁波在信道中传播所需要的时是指电磁波在信道中传播所需要的时间。取决于电磁波在信道上的传播速率以及传输间。取决于电磁波在信道上的传播速率以及传输的距离。的距离。 电路交换电路交换: 最短,电磁波在电路

16、中传播的速率最短,电磁波在电路中传播的速率 为为20万公里万公里/秒。秒。 报文交换报文交换: 最长最长; 分组交换分组交换: 3 可靠性可靠性:o电路交换电路交换: 报文交换报文交换:分组交换分组交换: 每个分组在网络中传输时可以在中继线和用户每个分组在网络中传输时可以在中继线和用户线上分段进行差错校验,使信息在分组交换网络中传输的线上分段进行差错校验,使信息在分组交换网络中传输的比特差错率大大降低,一般可以达到比特差错率大大降低,一般可以达到 以下。以下。11104 对系统业务过载的反应对系统业务过载的反应: 电路交换电路交换: 有呼损有呼损; 当对方用户终端设备忙或交换网负当对方用户终端

17、设备忙或交换网负 载过重而呼叫不通。载过重而呼叫不通。 报文交换报文交换: 存储存储-转发,当业务过载,发不出去,在交转发,当业务过载,发不出去,在交 换机内部存储,增加了报文传输时延。换机内部存储,增加了报文传输时延。 分组交换分组交换: 有流量控制机制有流量控制机制, 通过抑制、控制发送方降低通过抑制、控制发送方降低 发送速率,甚至停止发送。发送速率,甚至停止发送。5 信息传输的透明性信息传输的透明性 电路交换电路交换: 信息以数字信号形式在数据通路中信息以数字信号形式在数据通路中“透明透明”传传 输,交换机对用户的数据信息不输,交换机对用户的数据信息不 存储、分析和处理。存储、分析和处理

18、。 报文交换报文交换: 不透明不透明 分组交换分组交换: 不透明不透明6 异种终端的互通异种终端的互通 电路交换电路交换: 通信双方在信息传输、编码格式、通信双方在信息传输、编码格式、 同步方式、通信协议等方面要完全同步方式、通信协议等方面要完全 兼容,这就限制了各种不同速率、兼容,这就限制了各种不同速率、 不同代码格式、不同通信协议的用不同代码格式、不同通信协议的用 户终端直接的互通。户终端直接的互通。 分组、报文分组、报文: 报文报文(分组分组)以存储转发方式通过交以存储转发方式通过交 换机,输入输出电路的速率、编码换机,输入输出电路的速率、编码 格式等可以不同,很容易实现各种格式等可以不

19、同,很容易实现各种 不同类型终端之间的相互通信。不同类型终端之间的相互通信。7 多功能通信多功能通信 (同文广播同文广播) 电路交换电路交换: 不支持多功能通信不支持多功能通信报文交换、分组交换报文交换、分组交换: 根据报文指定的一个或多个目的地址根据报文指定的一个或多个目的地址 ,只只 需发送一次。从用户的角度来看,支持多需发送一次。从用户的角度来看,支持多 功能通信。功能通信。 8 电路的利用率电路的利用率 电路交换电路交换: 连接建立后,电路资源被通信双方独占连接建立后,电路资源被通信双方独占(即使无数即使无数据据),电路利用率低。电路的接续时间长,当传输较短,电路利用率低。电路的接续时

20、间长,当传输较短信息时,通信通路建立的时间可能将大于通信时间,信息时,通信通路建立的时间可能将大于通信时间,网络利用率低。网络利用率低。 报文交换、分组交换报文交换、分组交换: 可实现线路动态统计复用,资源利用率高可实现线路动态统计复用,资源利用率高一个用户可以同时进行多个通信一个用户可以同时进行多个通信 (如发(如发E-mail,通话,下载文件可同时进行)通话,下载文件可同时进行)ISO/OSI数据链路层数据链路层物理层物理层网络层网络层传输层传输层应用层应用层表示层表示层会话层会话层通路通路控制控制数据链路控制数据链路控制物理层物理层传输控制传输控制端用户端用户功能管理服务功能管理服务数据

21、流控制数据流控制路由控制路由控制传输组传输组数据链路控制数据链路控制物理层物理层网络服务网络服务端用户端用户网络应用网络应用会话控制会话控制传输控制传输控制IMP-IMP物理层物理层HOST-HOST用户层用户层文件传输协议文件传输协议远程通信协议远程通信协议源源IMP-目的目的IMP网络接口层网络接口层IPTCP/UDP应用应用ARPASNADNATCP/IP网络层数据链路层物理层运输层应用层表示层会话层ISO/OSI 模型网际层IP网络接口层运输层TCP、UDP应用层(FTP、SNMP、TELNET)TCP/IP 体系结构qOSI的专家们缺乏实际经验,他们在完成的专家们缺乏实际经验,他们在

22、完成OSI标准时没有商业驱动力标准时没有商业驱动力;qOSI的协议实现起来过分复杂,而且运行效的协议实现起来过分复杂,而且运行效率很低率很低;qOSI标准的制订周期太长,因而使得按标准的制订周期太长,因而使得按OSI标准生产的设备无法及时进入市场标准生产的设备无法及时进入市场研究研究投资投资活动活动时间时间标准标准 原理体系结构网络层数据链路层运输层应用层物理层1.3 因特网发展的三个阶段n第一阶段是从单个网络 ARPANET 向互联网发展的过程。 n1983 年 TCP/IP 协议成为 ARPANET 上的标准协议。n人们把 1983 年作为因特网的诞生时间。 1969年,美国的分组交换网年

23、,美国的分组交换网ARPANET投入运行,当时仅有投入运行,当时仅有4个个node。1983年,连接年,连接300台计算机。台计算机。1984年,年, ARPANET分解成两个网络。一个仍称为分解成两个网络。一个仍称为ARPANET,是民用科研网,另一个是军用计算机网是民用科研网,另一个是军用计算机网MILNET.1985年,年,NSF围绕其围绕其6个大型计算中心建设计算机网络。个大型计算中心建设计算机网络。1986年,建成国家自然科学基金网年,建成国家自然科学基金网NSFNET,其为一个三级其为一个三级计算机网络,包括主干网、地区网和校园网,覆盖了全美计算机网络,包括主干网、地区网和校园网,

24、覆盖了全美国主要的大学和研究所。国主要的大学和研究所。NSFNET后来接管了后来接管了ARPANET,并改为并改为Internet。最初最初NSFNET的主干网的速率不高,仅为的主干网的速率不高,仅为56kb/s。在在1989-1990年,提高为年,提高为1.544Mb/s, 1993年年45Mb/s, 1996年年155Mb/s。 1999年,年,622Mb/s, 目前,主干网的速率高达目前,主干网的速率高达Gb/s,10Gb/s。75753535131312124 40 010102020303040405050606070708080电话电话收音机收音机电视机电视机移动电话移动电话Int

25、ernetInternetl标准对于保证不同厂家生产的产品的协调工作是至标准对于保证不同厂家生产的产品的协调工作是至关重要的。关重要的。l标准不仅使不同的计算机能通信,而且可以使符合标准不仅使不同的计算机能通信,而且可以使符合标准的产品扩大市场,这将导致大规模生产、制造标准的产品扩大市场,这将导致大规模生产、制造业的规模经济、业的规模经济、VLSI实现,以及降低成本并更进实现,以及降低成本并更进一步提高用户的可接受性。一步提高用户的可接受性。l标准可以分为两大类:法定标准和事实标准标准可以分为两大类:法定标准和事实标准l法定标准是那些被官方认可的组织制定的。法定标准是那些被官方认可的组织制定的

26、。l未被官方认可的、但却在实际应用中被广泛采用的未被官方认可的、但却在实际应用中被广泛采用的标准称为事实标准。标准称为事实标准。国际电信联盟国际电信联盟( I T U )国际标准化组织国际标准化组织( I S O ) OSI N7 layer美国国家标准协会美国国家标准协会( A N S I ) SONET美国电气电子工程师协会美国电气电子工程师协会( I E E E ) 802 (Institute of Electrical and Electronics Engineers) 美国电子工业联合会美国电子工业联合会( E I A )和相关的电和相关的电信工业联合会信工业联合会( T I A

27、 )Internet 协会协会( I S O C ) l1992年年 国际性组织国际性组织Internet协会协会(ISOC)成立,负责全面管理成立,负责全面管理Internet。lInternet体系结构委员会体系结构委员会IAB(Internet Architecture Board)为为ISOC下的一个技术组织,负责管理下的一个技术组织,负责管理Internet有关协议的开发。有关协议的开发。lIAB下设网络工程部下设网络工程部IETF(Internet Engineering Task Force)和网和网络研究部络研究部IRTF (Internet Research Task For

28、ce)。IETF下设工作下设工作组集中研究短期和中期的工程问题,主要是对协议的开发和标组集中研究短期和中期的工程问题,主要是对协议的开发和标准化。准化。IRTF下设研究组,侧重从理论方面研究和开发一些需要下设研究组,侧重从理论方面研究和开发一些需要长期考虑的问题。长期考虑的问题。ISOCIABIETFIRTFl所有的所有的Internet标准都是以标准都是以RFC的形式发表的。的形式发表的。l普通的普通的RFC文档成为文档成为Internet的正式标准要经过四个的正式标准要经过四个阶段阶段: 1 Internet draft; 2 proposed standard 3 draft stand

29、ard; 4 official standardl所有的所有的RFC文档、包括各种文档、包括各种Internet标准都可以从网标准都可以从网上免费下载。上免费下载。l一些一些RFC文档举例文档举例l1986 RFC 0977 Network News Transfer Protocol. B.Kantor,l1995 RFC 1883 Internet Protocol, Version6(IPv6) Specification.S.Deening,l1996 RFC 1945 Hypertext Transfer Protocol, T.Berners-Lee,l1999 RFC 2570

30、Introduction to Version 3 of the Internet-Introduction to Version 3 of the Internet-standard Network Management Framework,standard Network Management Framework, l1999 RFC 2571 An Architecture for Describing SNMP Management Frameworks,l1999 RFC 2574 User-based Security Model (USM) for version 3 of th

31、e Simple Network Management Protocol (SNMPv3)l1999 RFC 2575 View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)l2000 RFC 2863 The Interfaces Group MIBl2006 RFC 4741 NETCONF Configuration Protocoll2008 RFC 5357 Two-Way Active Measurement Protocol (TWAMP)1 按网络的交换功能

32、按网络的交换功能: 电路交换电路交换,报文交换报文交换,分组交换。分组交换。2 按网络的使用范围:按网络的使用范围: 公用网公用网: 是指国家的电信部门建造的网络。公用的意思是指所是指国家的电信部门建造的网络。公用的意思是指所有愿意按电信部门规定交纳费用的人都可以使用。有愿意按电信部门规定交纳费用的人都可以使用。 专用网专用网:某个部门为本单位的特殊业务工作的需要而建造的网某个部门为本单位的特殊业务工作的需要而建造的网络。这种网络不向本单位以外的人提供服务。例如络。这种网络不向本单位以外的人提供服务。例如,军队军队,铁路铁路,电电力等系统均有本系统的专用网。力等系统均有本系统的专用网。3 按网

33、络的作用范围按网络的作用范围: 局域网局域网(LAN) 、城域网、城域网(MAN)和广域网和广域网(WAN), 。 局域网局域网:局域网通常是私有的,用于连接一个办公室、建筑物或是局域网通常是私有的,用于连接一个办公室、建筑物或是 校园内的设备,局域网的范围被限定在几公里之内。校园内的设备,局域网的范围被限定在几公里之内。 城域网城域网:城域网将网络覆盖范围延伸到整个城市,地理范围几十城域网将网络覆盖范围延伸到整个城市,地理范围几十 公里到上百公里,对硬件、软件的要求比局域网高。公里到上百公里,对硬件、软件的要求比局域网高。 广域网广域网:可把众多的局域网和城域网连接起来。提供跨越辽阔的地可把

34、众多的局域网和城域网连接起来。提供跨越辽阔的地理距离进行长距离的数据、语音、图片和视频传输的功能。理距离进行长距离的数据、语音、图片和视频传输的功能。分布式系统的最大特点是整个系统中的各个计算机分布式系统的最大特点是整个系统中的各个计算机对用户都是透明的。对用户都是透明的。计算机网络则不同,用户必须先在欲运行程序的计计算机网络则不同,用户必须先在欲运行程序的计算机进行登录,然后按照该计算机的地址,将程序算机进行登录,然后按照该计算机的地址,将程序通过计算机网络传送到该计算机上运行。最后,根通过计算机网络传送到该计算机上运行。最后,根据用户的命令将结果传送到指定的计算机。由此可据用户的命令将结果

35、传送到指定的计算机。由此可见,计算机网络并不等于分布式计算机系统。见,计算机网络并不等于分布式计算机系统。数据链路层电话交谈计费、安全实时性宽带能力交换或寻址主要功能智能双向通信电视传送数据传送电话网 计算机网 有线电视网 三种网络的主要特点及演变方向q数字技术使电话、数据和图像业务都可以数字技术使电话、数据和图像业务都可以统一编码传输和交换,而无任何区别。统一编码传输和交换,而无任何区别。q光通信技术的发展为传送各种业务信息提光通信技术的发展为传送各种业务信息提供了必要的带宽、传输质量和低成本。供了必要的带宽、传输质量和低成本。q软件技术软件技术使三种网络都能通过软件变更最使三种网络都能通过

36、软件变更最终支持各种用户所需的特性、功能和业务终支持各种用户所需的特性、功能和业务q统一的统一的TCP/IPTCP/IP协议的普遍采用使得各种以协议的普遍采用使得各种以IP为基础的业务都能实现互通。人类首次有为基础的业务都能实现互通。人类首次有了为三大网络都能接受的通信协议。了为三大网络都能接受的通信协议。l拓扑是指网络物理布置的方式。拓扑是指网络物理布置的方式。(通信子网通信子网的结构的结构)l网络拓扑是所有链路和连接的所有设备网络拓扑是所有链路和连接的所有设备互相之间关系的几何表示。互相之间关系的几何表示。l几种主要的拓扑结构几种主要的拓扑结构拓扑结构不同,其访问技术、性能、应用场拓扑结构

37、不同,其访问技术、性能、应用场合等也不同合等也不同l延迟、吞吐率、可靠性、信道利用率、设备开延迟、吞吐率、可靠性、信道利用率、设备开销销 .拓扑拓扑网状拓扑网状拓扑星型拓扑星型拓扑总线拓扑总线拓扑树型拓扑树型拓扑环型拓扑环型拓扑q特征特征每一个设备都与其他所有设备有一条专线连接每一个设备都与其他所有设备有一条专线连接q优点优点专用链路专用链路健壮性健壮性私有性私有性方便故障检测方便故障检测q缺点缺点数量巨大数量巨大 N(N-1)/2l特征特征 由一条长由一条长电缆组成电缆组成的主干和的主干和连接在上连接在上面的网络面的网络设备组成设备组成l优点优点小型网络小型网络比较便宜比较便宜l缺点缺点管理

38、的成管理的成本非常高本非常高网络流量网络流量小小l主要组件主要组件总线总线终结器终结器l电阻电阻l阻塞信阻塞信号号特点特点数据的路径是连续的,没有逻辑的数据的路径是连续的,没有逻辑的起点与终点起点与终点;单环;双环单环;双环优点优点1 1 管理起来比总线管理起来比总线拓扑结构要容易拓扑结构要容易2 2 网络流量优于总网络流量优于总线拓扑结构线拓扑结构缺点缺点1 1 比总线拓扑结构比总线拓扑结构要昂贵要昂贵2 2 设备选项较少设备选项较少特点:特点: 中央集线器中央集线器 多个结点多个结点每个设备只与通常称为集线器的中每个设备只与通常称为集线器的中心控制器有点到点的专用链路。心控制器有点到点的专

39、用链路。优点优点1 1 启动成本目前比总启动成本目前比总线网络和环形网络低线网络和环形网络低2 2 比传统的总线网络比传统的总线网络易于管理易于管理3 3 容易扩展容易扩展4 4 应用广泛应用广泛缺点缺点1 1 集线器是单失效点集线器是单失效点2 2 需要的电缆比总线需要的电缆比总线拓扑结构多拓扑结构多特点特点设备首先连接到一个次级集线设备首先连接到一个次级集线器上,再由次级集线器连接到器上,再由次级集线器连接到中央集线器上中央集线器上优点优点更多设备连接更多设备连接增加了传输距离增加了传输距离隔离不同计算机通信隔离不同计算机通信设定计算机通信的优设定计算机通信的优先级先级l通常一个网络会把几个采取不同拓扑结通常一个网络会把几个采取不同拓扑结构的子网在一个更大的拓扑结构中结合构的子网在一个更大的拓扑结构中结合在一起在一起l“带宽带宽”(bandwidth)本来是指信号具有本来是指信号具有的频带

温馨提示

  • 1. 本站所有资源如无特殊说明,都需要本地电脑安装OFFICE2007和PDF阅读器。图纸软件为CAD,CAXA,PROE,UG,SolidWorks等.压缩文件请下载最新的WinRAR软件解压。
  • 2. 本站的文档不包含任何第三方提供的附件图纸等,如果需要附件,请联系上传者。文件的所有权益归上传用户所有。
  • 3. 本站RAR压缩包中若带图纸,网页内容里面会有图纸预览,若没有图纸预览就没有图纸。
  • 4. 未经权益所有人同意不得将文件中的内容挪作商业或盈利用途。
  • 5. 人人文库网仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对用户上传分享的文档内容本身不做任何修改或编辑,并不能对任何下载内容负责。
  • 6. 下载文件中如有侵权或不适当内容,请与我们联系,我们立即纠正。
  • 7. 本站不保证下载资源的准确性、安全性和完整性, 同时也不承担用户因使用这些下载资源对自己和他人造成任何形式的伤害或损失。

评论

0/150

提交评论